1

I am facing this bug since few days.

I am using: Rpi 3b+ or Rpi0W, Buster-lite with last update, Kernel : 4.19.118+

I using Ubiquti WiFi AP and dnsmasq for managing the lan, both working normally with other machines (debian), The Wifi RSSI Signal is very good for Rpis, The bug is happening only during the day untimely, I have running a script which do http Requests on the web (python).

I have tried several solution found in forums: Disabled Power_save option, wpa_cli scanning every 120 scds, pinging each two second,

After Wifi lost, Rpi reconnect but it can take more than few minutes. Any ideas ? How to resolve this ?

    Jul 30 14:44:54 raspi6 dhcpcd[376]: wlan0: carrier lost
Jul 30 14:44:54 raspi6 dhcpcd[376]: wlan0: deleting address fe80::5260:eec7:70e2:5716
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Withdrawing address record for fe80::5260:eec7:70e2:5716 on wlan0.
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Leaving mDNS multicast group on interface wlan0.IPv6 with address fe80::5260:eec7:70e2:5716.
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Interface wlan0.IPv6 no longer relevant for mDNS.
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Withdrawing address record for 10.200.206.163 on wlan0.
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 10.200.206.163.
Jul 30 14:44:54 raspi6 avahi-daemon[241]: Interface wlan0.IPv4 no longer relevant for mDNS.
Jul 30 14:44:54 raspi6 dhcpcd[376]: wlan0: deleting route to 10.200.0.0/16
Jul 30 14:44:54 raspi6 dhcpcd[376]: wlan0: deleting default route via 10.200.0.1
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: carrier acquired
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: IAID eb:22:68:39
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: adding address fe80::5260:eec7:70e2:5716
Jul 30 14:45:41 raspi6 avahi-daemon[241]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::5260:eec7:70e2:5716.
Jul 30 14:45:41 raspi6 avahi-daemon[241]: New relevant interface wlan0.IPv6 for mDNS.
Jul 30 14:45:41 raspi6 avahi-daemon[241]: Registering new address record for fe80::5260:eec7:70e2:5716 on wlan0.*.
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: soliciting an IPv6 router
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: carrier acquired
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: IAID eb:22:68:39
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: adding address fe80::5260:eec7:70e2:5716
Jul 30 14:45:41 raspi6 avahi-daemon[241]: Joining mDNS multicast group on interface wlan0.IPv6 with address fe80::5260:eec7:70e2:5716.
Jul 30 14:45:41 raspi6 avahi-daemon[241]: New relevant interface wlan0.IPv6 for mDNS.
Jul 30 14:45:41 raspi6 avahi-daemon[241]: Registering new address record for fe80::5260:eec7:70e2:5716 on wlan0.*.
Jul 30 14:45:41 raspi6 dhcpcd[376]: wlan0: soliciting an IPv6 router
Jul 30 14:45:47 raspi6 dhcpcd[376]: wlan0: probing for an IPv4LL address
Jul 30 14:45:47 raspi6 dhcpcd[376]: wlan0: DHCP lease expired
Jul 30 14:45:47 raspi6 dhcpcd[376]: wlan0: soliciting a DHCP lease
Jul 30 14:45:52 raspi6 dhcpcd[376]: wlan0: using IPv4LL address 169.254.69.244
Jul 30 14:45:52 raspi6 avahi-daemon[241]: Joining mDNS multicast group on interface wlan0.IPv4 with address 169.254.69.244.
Jul 30 14:45:52 raspi6 dhcpcd[376]: wlan0: adding route to 169.254.0.0/16
Jul 30 14:45:52 raspi6 dhcpcd[376]: wlan0: adding default route
Jul 30 14:45:52 raspi6 avahi-daemon[241]: New relevant interface wlan0.IPv4 for mDNS.
Jul 30 14:45:52 raspi6 avahi-daemon[241]: Registering new address record for 169.254.69.244 on wlan0.IPv4.
Jul 30 14:45:54 raspi6 dhcpcd[376]: wlan0: no IPv6 Routers available
Jul 30 14:46:15 raspi6 dhcpcd[376]: wlan0: offered 10.200.206.163 from 10.200.0.1
Jul 30 14:46:15 raspi6 dhcpcd[376]: wlan0: probing address 10.200.206.163/16
Jul 30 14:46:20 raspi6 dhcpcd[376]: wlan0: leased 10.200.206.163 for 3600 seconds
Jul 30 14:46:20 raspi6 avahi-daemon[241]: Registering new address record for 10.200.206.163 on wlan0.IPv4.
Jul 30 14:46:20 raspi6 dhcpcd[376]: wlan0: adding route to 10.200.0.0/16
Jul 30 14:46:20 raspi6 dhcpcd[376]: wlan0: changing default route via 10.200.0.1
Jul 30 14:46:20 raspi6 avahi-daemon[241]: Withdrawing address record for 169.254.69.244 on wlan0.
Jul 30 14:46:20 raspi6 avahi-daemon[241]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 169.254.69.244.
Jul 30 14:46:21 raspi6 avahi-daemon[241]: Joining mDNS multicast group on interface wlan0.IPv4 with address 10.200.206.163.
Jul 30 14:46:20 raspi6 avahi-daemon[241]: Withdrawing address record for 169.254.69.244 on wlan0.
Jul 30 14:46:20 raspi6 avahi-daemon[241]: Leaving mDNS multicast group on interface wlan0.IPv4 with address 169.254.69.244.
Jul 30 14:46:21 raspi6 avahi-daemon[241]: Joining mDNS multicast group on interface wlan0.IPv4 with address 10.200.206.163.
11
  • The log does not help much. It only shows what dhcpcd and avahi-daemon is doing when a carrier is lost or gotten. There is normal action shown. What command to you use? Look what wpa_supplicant is doing with journalctl --boot --unit=wpa_supplicant.service and add this output instead. – Ingo Aug 7 '20 at 19:17
  • I have only this for journalctl --boot --unit=wpa_supplicant.service -- Logs begin at Mon 2020-08-17 16:03:32 CEST, end at Mon 2020-08-17 17:08:05 CEST. -- -- No entries -- – Hamouche Abaouz Aug 17 '20 at 15:08
  • I don't know what's wrong with your setup. On an unmodified Raspberry Pi OS Buster Lite I get: -- Logs begin at Mon 2020-08-17 19:43:04 BST, end at Mon 2020-08-17 19:44:49 BST. -- Aug 17 19:43:07 raspberrypi systemd[1]: Starting WPA supplicant... Aug 17 19:43:08 raspberrypi wpa_supplicant[488]: Successfully initialized wpa_supplicant Aug 17 19:43:08 raspberrypi systemd[1]: Started WPA supplicant. – Ingo Aug 17 '20 at 18:53
  • you are right, the result above come from buster full OS, from buster lite i have : -- Logs begin at Wed 2020-08-05 15:17:01 CEST, end at Tue 2020-08-18 09:44:44 CEST. -- Aug 05 15:17:15 raspberrypi1 systemd[1]: Starting WPA supplicant... Aug 05 15:17:16 raspberrypi1 wpa_supplicant[248]: Successfully initialized wpa_supplicant Aug 05 15:17:17 raspberrypi1 systemd[1]: Started WPA supplicant. But the bug is the same in all buster version full, normal, and lite buster – Hamouche Abaouz Aug 18 '20 at 7:50
  • Between an unmodified RaspiOS Lite and Full version there is no difference in networking. The Full version should give the same output. It seems the default systemd service management is broken on your system. This may give you problems. – Ingo Aug 18 '20 at 14:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.