2

Well, today is turning out to be a bit of a pain with disk drives (esp with zero sleep last night).

I have an external ICY BOX JBOD box with one Seagate Barracuda and one Samsung Momentus drive in it and both drives being accessed about every second or so going by the activity lights.

Neither drive is the boot drive - the Pi B+ (v1.2) is booting from an SD card with an up to date Buster Light on it.

No applications are running on the Pi and the disk is not being accessed by anything else on the LAN.

The only things I can see is the task 'usb-storage' coming up to the top of TOP.

lsusb returns:

Bus 001 Device 004: ID 067b:2773 Prolific Technology, Inc. PL2773 SATAII bridge controller

lsusb -t gives:

/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=dwc_otg/1p, 480M
    |__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/5p, 480M
        |__ Port 1: Dev 3, If 0, Class=Vendor Specific Class, Driver=smsc95xx, 480M
        |__ Port 5: Dev 4, If 0, Class=Mass Storage, Driver=usb-storage, 480M

top shows usb-storage nearly always at the highest CPU when nothing else is running on the system.

fstab line for this drive is

LABEL=FileArchive /mnt/FileArchive ext4 nofail,defaults,noatime 0 1

I've tried killing the process to double check it is this but to no avail - it does not want to die.

Checking before and after the drive is attached dmesg | grep usb-storage

Before gives

[    2.592298] usbcore: registered new interface driver usb-storage

and after

[    2.592298] usbcore: registered new interface driver usb-storage
[  222.734216] usb-storage 1-1.5:1.0: USB Mass Storage device detected
[  222.741069] scsi host0: usb-storage 1-1.5:1.0

but as soon as I issue the mount command (either manually or via sudo mount -a, the access starts again.

I ran sudo e2fsck -vf /dev/sda1 but that came up clean.

Trying the Samsung drive in another USB hub does not show the activity flash and I've tried adding usb-storage.quirks=067b:2773u to the start of cmdline.txt (yes I know the USB ports are only USB 2 on the Pi - I'll try anything at the moment) but that did not help.

Any ideas?

  • Do you use any types of external power port for those drives? – Sohan Arafat Aug 7 at 0:30
  • The units are a full enclosure with its own 12v 4Amp supply raidsonic.de/products/external_cases/external_cases_35/… so it's not a power issue - I have two and it does the same on both with WD / Seagate / Samsung and a Toshiba disks - mix of sizes (1-5TB) And footprint 2.5 and 3.5" Reasearching yesterday shows it's an issue with the USB 2 -> 3 on the 2773 chip as it supports TWO drives but the kernel driver teams closed an issue as noted our problem' but in some distros and machines it works - cannot buy a new PC to run a disk drive box! – Andyroo Aug 7 at 1:29
  • what happens if you unmount the drives? – jsotola Aug 12 at 6:09
2

If there's a userspace process that keeps the drive busy, running lsof /mnt/FileArchive while the partition is mounted should list it.

If the activity is internal to the mass storage driver, it could be due to filesystem error. Unmount the partition and check it manually with fsck.

On an unrelated note, you're setting fs_passno to 1 in fstab for no visible reason. If you want a non-root partition to be ckecked at mount, set its fs_passno to 2.

| improve this answer | |
0

I have essentially the same setup except: two platter drives on a Rpi-3.

Take a look at the file "/etc/mtab". It is a "ln -S" link into /proc. The file shows how the disks were mounted exactly by the file system.

My two drives spin down when not in use. I use mine for network backups. When I login in takes about 30 seconds for the disks to spin back up and the disk encryption to be re-applied. The disk encryption takes a while to execute, so I hand run a script so the boot doesn't stall. The "noauto" command makes sure the Linux doesn't do the mount.

/etc/fstab looks like:

/dev/mapper/u4 /u4 ext4 defaults,noauto 0 0

but /etc/fstab looks like:

/dev/mapper/u4 /u4 ext4 rw,relatime,stripe=2,data=ordered 0 0

| improve this answer | |
0

I agree with @jow about that. I have had this problem before on my RasPi A+ too. Anyway, I tried to fix it by running

root@localhost# sudo e2fsck -vf /dev/sda1

too, although I got a "Non-existent file or directory" error with code 4092. I eventually (after a month or so) fixed it with

root@localhost# sudo e2fsck -vf /run/mount

and that worked for me perfectly.

Anyway, hope that helped,

N.T.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.