0

I connect to a headless Pi from my Mac. I've set resolution in raspi-config, I've manually edited /boot/config.txt, and when I select Screen Configuration at the desktop (VNC'd in from the Mac) nothing happens. I've done this all in the past, but the new lack of a screen resolution menu item means whatever I used to do no longer works. I'm sure this is a well-known issue, but I can't find any reference to it here.

64-bit Raspberry Pi OS, newly installed. Booting from SATA SSD. I installed Real VNC Server to connect (which I have to manually launch every time I reboot even after setting it up to autoload which is another irritation I need to deal with after I can get more than a postage-stamp-sized screen to work in.)

7
  • If you want help you need to explain what you ACTUALLY did. "I've manually edited /boot/config.txt" is meaningless.
    – Milliways
    Aug 8, 2020 at 2:55
  • Do you know that the 64-bit Raspberry Pi OS is an unstable beta release? Maybe you file a bug report to the developers?
    – Ingo
    Aug 8, 2020 at 11:42
  • @Milliways, what I actually did was set the resolution in raspi-config and edited /boot/config.txt to uncomment framebuffer_width and _height and set them to 1920 and 1080 respectively. The post you referenced mentioned uncommenting hdmi_force_hotplug=1 which must be the default now because it was already uncommented in my copy. After another pass through RPi Foundation's docs, I've also tried duplicating settings for both HDMI 0 and 1. No love—all RealVNC ever sees is 1024x768.
    – rsswtmr
    Aug 10, 2020 at 14:45
  • @Ingo, yes I'm aware that it's a beta release, but wanted to research and ensure that my issue was in fact a bug and not just an oversight on my part. I'm self-aware enough to know that it's most probably my fault.
    – rsswtmr
    Aug 10, 2020 at 14:45

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.