0

I tried to set up a bridge to extend my wifi connection following the instructions here.

Some background: I've followed this setup before and it worked. I also added a bind9 server to host my own DNS. Both were working well until recently when my raspberry pi randomly shut down. I restarted it with no internet access. I also stopped using it as a DNS because I couldn't be bothered to fix it at the time.

Today I started my once fully connected raspberry pi to find that it could not access the internet; it was trying to resolve DNS through 127.0.0.1. Thinking that this was a bind9 issue, I uninstalled bind9 and purged it, but to no avail; now there was just no DNS server. I tried again by undoing the steps in the access point bridge and uninstalled hostapd and I regained internet access. Going through and re-doing those changes caused me to lose my internet connection once again.

Since I can't ssh into my raspberry device, it's hard to copy paste files, so I'll type the non-comments from these files:

/etc/dhcpcd.conf

denyinterfaces wlan0 eth0

hostname

clientid

persistent

option rapid_commit

option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes

poption interface_mtu

require dhcp_server_identifier

slaac private

interface eth0
interface br0

/etc/network/interfaces

source-directory /etc/network/interfaces.d

0

Update: I unplugged the ethernet cable, commented out interface eth0 (I did this before and rebooted but it didn't work), restarted the device, waited for everything to load and plugged the ethernet cable back in and it works again. I'm not sure why it worked this time and why unplugging and re-plugging the ethernet made a difference (if it did).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.