0

The problem:

  • I am trying to use a RW1820 (DS18B20), to display the temperature. yet it does not show up in devices. Only w1_bus_master 1 appears.

Setup:

  • Raspberry Pi 4
  • 1-Wire Temperature Sensor Module – RW1820 (DS18B20)

Wiresetup:

  • Ground to pin 9 (pin 6 is in use due to a cooling fan)
  • Data to Gpio4 (pin 7)
  • VCC to pin 2

Steps I took:

Things I tried:

  • Connected the DS18b20 to my Arduino, sensor worked.
  • Used the same cables I used with the arduino for connecting to the Rpi, cables are okay.
  • Tried using the sensor on 3.3v, no effect
  • Inside the config.txt, I cut and pasted dtoverlay=w1-gpio on multiple lines (made sure only one was uncommented), no effect.

Photos: Connection with Rpi Connection with Sensor

Config content:

# For more options and information see
# http://rpf.io/configtxt
# Some settings may impact device functionality. See link above for details

# uncomment if you get no picture on HDMI for a default "safe" mode
#hdmi_safe=1

# uncomment this if your display has a black border of unused pixels visible
# and your display can output without overscan
#disable_overscan=1

# uncomment the following to adjust overscan. Use positive numbers if console
# goes off screen, and negative if there is too much border
#overscan_left=16
#overscan_right=16
#overscan_top=16
#overscan_bottom=16

# uncomment to force a console size. By default it will be display's size minus
# overscan.
#framebuffer_width=1280
#framebuffer_height=720

# uncomment if hdmi display is not detected and composite is being output
#hdmi_force_hotplug=1

# uncomment to force a specific HDMI mode (this will force VGA)
#hdmi_group=1
#hdmi_mode=1

# uncomment to force a HDMI mode rather than DVI. This can make audio work in
# DMT (computer monitor) modes
#hdmi_drive=2

# uncomment to increase signal to HDMI, if you have interference, blanking, or
# no display
#config_hdmi_boost=4

# uncomment for composite PAL
#sdtv_mode=2

#uncomment to overclock the arm. 700 MHz is the default.
#arm_freq=800

# Uncomment some or all of these to enable the optional hardware interfaces
#dtparam=i2c_arm=on
#dtparam=i2s=on
#dtparam=spi=on

# Uncomment this to enable infrared communication.
#dtoverlay=gpio-ir,gpio_pin=17
#dtoverlay=gpio-ir-tx,gpio_pin=18

# Additional overlays and parameters are documented /boot/overlays/README

# Enable audio (loads snd_bcm2835)
dtparam=audio=on

[pi4]
# Enable DRM VC4 V3D driver on top of the dispmanx display stack
dtoverlay=vc4-fkms-v3d
max_framebuffers=2

[all]
#dtoverlay=vc4-fkms-v3d
dtoverlay=w1-gpio

Who has any idea what is going wrong? Could one of my GPIO pins be broken?

  • 2
    We need a clear photo showing the connections between the sensor and the Pi. We also need to see the contents of /boot/config.txt. – joan Aug 11 at 14:21
  • 1
    Post updated with the requested information – Anton van der Wel Aug 11 at 14:42
  • 1
    This might help: raspberrypi.stackexchange.com/questions/100203/…. – tlfong01 Aug 11 at 14:45
  • 2
    I presume G (brown) is ground, R (red) is data, and Y (orange) is +ve. Is that what you have? – joan Aug 11 at 15:40
  • 1
    That is correct! – Anton van der Wel Aug 11 at 15:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.