Yesterday when I tried to boot my Pi 3b+ like the usual, it's red LED lit up very faintly and it's green LED showed no activity, so I switched off the power supply and switched it back on again. This time it lit up and the (sense) hat on top of it lit up too but it got stuck like that. I know it didn't boot because I tried SSHing into it with no results. I tried burning Rasbian on a new (FAT32) microSD with ssh and wifi configs. This time the Pi's red light glowed brightly, the green light didn't and the hat flashed for a fraction of a second. It didn't boot. Could you please tell me what on earth happened to it all of a sudden?

I have using for a few months, I keep it in a dry place and power it with a 5V, 2 A supply. I don't use any other peripherals with it. I have tried different power supplies of the same rating.

  • Try a different power supply.
    – joan
    Commented Aug 12, 2020 at 7:56
  • Tried that. Didn't help. Commented Aug 12, 2020 at 7:58
  • try another one - or a different cable if you used the same cable with the second power supply (assuming the power supply doesn't have attached cable of course) Commented Aug 12, 2020 at 10:11
  • Raspbian cannot boot from a single FAT32 partition, it typically uses FAT32 for boot and EXT4 for root. Are you sure you're flashing the SD card correctly? Commented Aug 12, 2020 at 14:20

1 Answer 1


OP said, "power it with a 5V, 2 A supply. I don't use any peripherals with it."

OP also said, "the (sense) hat on top of it lit up too" (emphasis mine)

Raspberry Pi docs said:

Recommended PSU current capacity for Pi 3B+: 2.5A

And so you'll have to excuse those of us who wonder if you've a) not done your homework, and b) wandered in with an attitude. We can't tell you what happened; I can't even hazard a guess. But I do think the answer to your question won't be had with your approach. I'd suggest you start over - take a measurement if you can, try troubleshooting (remove HAT, different cable) and edit your question.

  • I know that 5V, 2A isn't enough but that is all I have and it been working like that forever without any issues. I'll try removing the hat and give an update... Commented Aug 12, 2020 at 13:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.