3

I want to build a smooth experience on a Raspberry PI, and screen tearing is destroying transitions and animations on a web application viewed in chromium in full-screen, I'm using a 7" touchscreen display, but desktop monitor behaves the same.

I tried manually setting the timings in /boot/config.txt but with no success.

I tried disabling the xcompmgr composition manager and it apparently removed screen tearing only on video playback in chromium.

Does anyone have a screen tearing free config.txt or knows how to remove screen tearing from RPi?

UPDATE: tried compton but didn't solve the issue, animations look smoother but the screen still splits in half.

6
  • Which OS? Have you fully updated? – CoderMike Aug 14 '20 at 5:31
  • Linux raspberrypi 5.4.51-v7l+ #1327 armv7l - Raspberry Pi OS 32-bit, and its fully updated. – Andrei Krestyan Aug 14 '20 at 8:17
  • 1
    Try updating again. There was a massive update published this afternoon. – Dougie Aug 14 '20 at 22:40
  • I've been using Chromium on a Pi 4 for a long time now, and never saw the tearing issue. Do you see tearing on a vanilla system as well? – Dmitry Grigoryev Aug 16 '20 at 15:29
  • @DimitryGrigorev didn't cross my mind that the image i got from official sources would cause such issues, what system would you recommend ? – Andrei Krestyan Aug 19 '20 at 19:47
1

Disabling the Compositor might help. Type sudo raspi-config, go to Advanced Options, and turn it off. A solution specific to Chromium that might work is enabling Hardware Acceleration. You need to go to /usr/bin/ in the terminal and type chromium-browser --use-gl=egl.

I'm pretty sure a general purpose "screen tearing free config.txt" does not exist. If it did it would most likely be already implemented or it would be a popular answer to the multiple screen tearing problems posted on online forums like this.

5
  • i said that i did disable the compositor and it improved quality on some aspects but not browsing – Andrei Krestyan Aug 16 '20 at 9:38
  • @AndreiKrestyan Thanks, I updated my answer with another solution. – aklingam Aug 16 '20 at 13:58
  • AFAIK there is "no general purpose screen tearing config" because there is no tearing problem affecting general public. Or do you get tearing on a Pi 4 too? – Dmitry Grigoryev Aug 16 '20 at 15:45
  • @DmitryGrigoryev I found a few other people who had problems related to screen tearing on a Pi 4 on Reddit. reddit.com/r/raspberry_pi/comments/e9k0u3/… and reddit.com/r/raspberry_pi/comments/f1nett/…. I did also find other forums where people posted similar issues. An example: forum.vivaldi.net/topic/46540/…. I have also noticed similar issues on my Pi 3B+. – aklingam Aug 16 '20 at 17:14
  • @aklingam using Hardware Acceleration didn't help, also googled the issue before posting and saw the reddit threads, but didn't find any solution – Andrei Krestyan Aug 19 '20 at 19:43
1

I have a 75" LG TV with an Rpi4 box, the tearing was pretty awful (but I never saw this problem with my previous Rpi3 box.)

Here is what I did, and followed is my configuration which seems to have done the trick.

sudo apt-get install libgles2-mesa libgles2-mesa-dev xorg-dev

Here's my config file

[pi4]
cpu_freq=1800
over_voltage=5
gpu_freq=700

[all]
dtoverlay=vc4-fkms-v3d
gpu_mem=128
hdmi_drive=2
hdmi_group=1
hdmi_mode=76
dtparam=audio=on

No turbo flag, cpufrequtil or things like that. Short and simple config file. Chromium seems to work better without any tearing.

For your custom reference, altering the hdmi_mode flag may be the key. Here is an official list of references from the Rpi doc site:

https://www.raspberrypi.org/documentation/configuration/config-txt/video.md

I'm sure the config file can be improved upon, or my flags aren't 100% correct and are open to criticism, or maybe the drivers weren't necessary---but in the offshoot someone is still looking for answers, this may help.

0

As far as I am aware the 64 bit Pi OS has a 32 bit kernel and runs 32 bit apps like chromium. Check which chromium you have, help about chromium. To get the benefit of a 64 bit system and chromium you need a 64 bit OS. Then use 64 bit chromium and enable hardware acceleration...
https://www.dedoimedo.com/computers/rpi4-ubuntu-mate-hw-video-acceleration.html

It worked for me, no more screen tearing and no dropped frames watching youtube at 1080p @ 30 fps. (once settled down and do not move mouse during video)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.