0

I have a raspberry pi zero with raspbian buster OS. I followed this tutorial to set up station mode and access point mode simultaneously, and it works.

Question is now I cannot visit my rpi zero with ssh pi@raspberrypi.local , I'll have to type in it's IP address like ssh pi@192.168.1.101.

In the above link, at the "first step" it mentioned another link that removes avahi-daemon, I think that's why bonjour-zeroconf feature is disabled, because it needs avahi-daemon.

So How can I have wifi station mode and access point and also keep zeroconf, so that I can visit my rpi with XXX.local?

1
  • You are right. I didn't have a focus on zeroconf and I have to revise it. There are settings available in the /etc/systemd/network/*.network files like LinkLocalAddressing=yes|no and MulticastDNS=yes|no. There may also be related information at man systemd.dnssd. I will look at it next because I'm just busy with another project. Please be patient a bit.
    – Ingo
    Aug 20, 2020 at 9:23

1 Answer 1

2

We use systemd-networkd which has its own multicast DNS system. That is the reason why we deinstall the avahi-daemon to avoid conflicts.

It is simple to enable multicast DNS with adding an option to the /etc/systemd/network/*.network configuration files. I have revised the setup for an Access point as WiFi router/repeater, optional with bridge that you used. Have a look at the *.network configuration files. On some you will find additional options:

LLMNR=no
MulticastDNS=yes

Add these also to your setup and you should find raspberrypi.local again. Check with:

laptop ~$ resolvectl query raspberrypi.local
raspberrypi.local: 192.168.50.26               -- link: wlan0

-- Information acquired via protocol mDNS/IPv4 in 269.0ms.
-- Data is authenticated: no

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.