1

I bought Pi 4 Model B recently from an official seller.

Then I installed raspberry pi OS 32 bit as it was mentioned on site.

I completed the installation setup and everything was working fine! Wi-Fi was working fine too..

After 3 days when I turned it back on surprisingly it was not connecting to my network through Wi-Fi!

I could not figure out why this was happening so I reinstalled the OS and now during setup I get this message while connecting to WIFI: Failed to connect to Network

I double checked password for my router, everything matches.

Is this problem normal for the Pi? I am worried about whether my Pi is damaged. enter image description here


Here's an update to this issue

I tried connecting a Wi-Fi adapter and after a quick reboot the internet got connected through it. But I am still having no luck with the on-board Wi-Fi: enter image description here.


After disconnecting the Wi-Fi adapter surprisingly the onboard Wi-Fi picks up the already connected network. I rechecked by rebooting the Pi multiple times and it is working fine now!


EDIT:

It worked fine for sometimes! NOW it's not working!!

2
  • Did you get the language up? It's needed for WiFi to work. Also a reboot of the router may help. – user115418 Aug 24 '20 at 18:42
  • @Andyroo Well I did complete the language and country setup successfully, there was no error message there. I tried rebooting the router too.. it's not working! – luckyCasualGuy Aug 25 '20 at 11:40
3

I don't know why but this worked for me! This method is quite strange though I don't take guarantee that it will work in all situations, it's just that it worked for me.

I urgently needed the internet connection on pi 4b so what I did was I connected a usb wifi adapter I had lying around.
It took some time for pi to recognize it and after a quick reboot the network got connected through adapter!
After my work on pi was done I removed the adapter and connected it to my desktop. When I came back to shutdown the pi I noticed that the pi was still connected to network. I was quite shocked!

I don't know how! but this works!

EDIT:

It worked fine for sometimes! NOW it's not working!!

EDIT:

According to: This post! dated: 2019-11-27 13:23

It appears that pi 4, until an update is released, will have wifi connecting problems on higher resolutions. you need to bootup your pi at lower resolutions (for me it worked at 640 * 480). After booting you can switch to high resolution!.
I tried other resolutions too but for me 640 * 480 only works!

2
  • Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as a unsolved Post to the community and saves them/us a lot of work. – Ingo Sep 5 '20 at 8:12
  • @Ingo I almost forgot about this :) – luckyCasualGuy Sep 5 '20 at 8:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.