0

I'm doing a project with a Pi 4B, the official touchscreen and the latest version of Raspberry Pi OS. I would like to connect to the Pi via VNC (RealVNC Viewer on Windows 10) at a higher resolution for development work.

I've enabled VNC in raspi-config, and it works perfectly when I use just the IP as the client address - the only issue is that it's fixed to the resolution of the touchscreen.

When I create another VNC server with vncserver -randr=1920x1080, I can connect to it on [IP address]:1. But I've found two issues (so far):

  • I get this error when I log in:

    GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication
    agent already exists for the given subject
    
  • The mouse cursor isn't correct - it's just an 'X' and isn't context sensitive.

The usual solution for the first issue (Untick "LXPolKit..." in Desktop Session Settings) doesn't apply here - that option isn't there. I have no idea how to fix the other issue.

Any idea how I sort these things out? I don't understand why the two VNC servers are behaving differently.

0

You can fix the black X issue with (I set my Pi's up with a script that is stateful and persistent through reboots)

# Fix the Black X problem
sudo cp /etc/vnc/xstartup /etc/vnc/xstartup.custom 
sudo sed -i 's/xsetroot -solid grey/xsetroot -solid grey -cursor\_name left_ptr/g' /etc/vnc/xstartup.custom

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.