0

I would like to write file raspbian boot folder via samba file server. But when i try to do it, raspbian doesn't allow me to writing file. How can I solve this problem. I have tried chmod command etc., but it didn't work. Could you help me if you have an idea about it. By the way, since I can only reach boot folder with windows explorer when i plug the sd card my windows computer, i want to write file boot folder.

3
  • you'll need to install and configure samba to allow this - as for writing to the boot partition with the sd card in a windows computer, the simple answer is you can't – Jaromanda X Aug 26 '20 at 9:28
  • so, is it possible that showing /home/pi (not /boot) directory when I plug an sd card to Windows computer – Omer ENEN Aug 26 '20 at 11:52
  • oh ... sorry, it's the ROOT you can't see in windows, of course you can see BOOT – Jaromanda X Aug 26 '20 at 12:07
0

The problem is probably that the Raspberry Pi mounts the /boot folder as root-owned because it's a VFAT partition. According to https://www.techrepublic.com/article/how-to-auto-mount-fat32-formatted-drives-in-samba/ you can work around this by editing /etc/fstab:

UUID=XXX /boot vfat dmask=000,fmask=111 0 0

where UUID is the UUID of your /boot partition.

Note: I haven't tried this myself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.