2

I'm trying to compile NancyFx on my raspberry using this guide but fail at step 5.

The command "rake mono" failes with the error

uninitialized constant Albacore:Task

So, I guess there is something wrong with my albacore installation. I've tried the install of albacore with the first command:

sudo gem install albacore

Which goes fine, also tried:

sudo gem install albacore --pre

Also goes fine, but does not solve the rake problem.

Also tried the workaround mentioned in the guide, by installing rubyzip 0.9.9.. installs fine but Nancy won't compile..

Now i'm out of options.

1

I had to go to 1.0.rc.2 to get it compiling. Also, I did a sudo su - before running instead of as pi. So

gem uninstall albacore
gem install albacore --version "~> 1.0.rc"

then rake mono

  • 1
    I just had the same error after installing Albacore v2.0.6. I may have to revert to something older. – patridge Sep 12 '14 at 19:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.