I've just installed two Seagate Ironwulf NAS harddisks of 4 TB in an Icy Box enclosure, Raid 1 set-up. I've setup a single partition using parted, and set up an ext4 filesystem. It's connected to a Raspberry Pi 4 running Raspberry Pi OS 10.

As soon as I mount the drive/partition, I hear the drive spin up as expected, and then a sound like a heartbeat can be heard - like the head is moving two times per second. Here's a recording of the sound.

This happens both when mounting manually via sudo mount -t ext4 /dev/sdb1 /mnt/IcyBox and when automounting. This 'heartbeat' stops as soon as I unmount the drive. It seems I can successfully write to the drive - the heartbeat continues.

Now, since I'm just mounting the drive, and no programme supposedly is using it, is there a way to find out why the drive is spinning?

And, more importantly: this doesn't happen when I mount the same drive on my Ubuntu (18.04.5) laptop. How does Raspberry PI OS handle mounted drives differently than Ubuntu, which could explain this difference in disk activity when mounting?

  • You need to add more info from logs. – MatsK Sep 2 '20 at 22:08
  • One simple check could be to install lsof and check if there's any file opened – Jaromanda X Sep 3 '20 at 2:03
  • Does the enclosure have its own power? – Michael Harvey Sep 3 '20 at 17:47
  • Thanks all for your comments. @MatsK, which logs should I add? What level? From which timeframe (I assume when mounting)? – Koen Sep 3 '20 at 20:09
  • @JaromandaX Thanks, I'll try that when I have the opportunity. – Koen Sep 3 '20 at 20:09

I think it's a bug / quirk in the usb driver - if you look at the output from the top command you will see the driver virtually consistently at the top.

I've been trying to sort the none raid ICY BOX drives I have (even had a bounty running) but to no avail. It seems fine on x86 boxes but not ARM. No matter what settings or ext versions I tried it just glitches. See this question

Checking the manufacturers web site the chips are not spec'd for LINUX in my boxes - I guess it's the same on the RAID versions.

I find this happens with no files on the drive by the way.

  • Shit, only seeing this now. Thank you for chipping in. I tried the top command and found systemd highly ranked all the time. Is that the driver you are are talking about? (sorry, I'm new to this stuff). Where exactly is the chip info listed? The product page on Raidsonic's website doesn't list that as far as I can see: raidsonic.de/products/external_cases/soho_raid/… – Koen Nov 21 '20 at 17:02
  • I use lsusb (possibly with sudo) and tracked down the chip set from that. The linked page has Windows >7, MAC OS X >10.5 as O/S – user115418 Nov 21 '20 at 18:40
  • Ah, I will see if I can track back the chip set also (though it's likely the same as your device). That linked page isn't strictly correct, given it works correctly with my Ubuntu laptop. Thanks - will update if I hear more from Raidsonic. – Koen Nov 22 '20 at 21:07

There is no real difference in the mounting between the raspberry pi's OS and your standard Ubuntu. It is likely that there is a process holding your disk. Use

lsof +f -- /dev/sda1


fuser -m /dev/sda1

to find out which process that might be. There are a number of processes that may be using your hard drive, but it depends a bit on what you installed. Here's a list I encountered (both on pi and other Linuces):

  • NFS
  • kjournald
  • updatedb

But there may be others.

However, if you can unmount the drive, there should not be a process holding your drive.

Also, ext4 accesses the drive from time to time; going back to ext2 will reduce the access (but you loose journaling). Adding noatime,nodiratime,commit=60 as mount-options may also reduce the accesses. This would be the same as on a non-pi OS, however.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.