0

I bought this canakit raspberry pi 4 and I have been trying to get retropie flashed on to this sd card, but raspberry pi imager is not recognizing the sd card. The card isnt bad because otherwise the raspberry pi wouldnt be able to run in the first place right? I tried this on a chromebook and the raspberry pi itself but neither was able to recognize the card.

1

This really is not a Pi issue as the Chromebook does not recognise the card hence the close request but things to check:

  • Do you have the read only switch in any adapter set?
  • Download SD Card formatter from here and use that first
  • Try Balena Etcher to write the image
  • If you have the OS running then install RetroPi onto it as per these instructions

Unfortunately, to help further a lot more info would have helped:

  1. A link to the kit you bought
  2. Details on the SD Card
  3. Any actual error messages
  4. Any steps you have actually tried to fix the errors
  5. Clarity over the Pi running - do you mean on the 'faulty' card or on another card

Unfortunately as we are remote it is hard to guess what you have done / seen but the above are places I start with iffy SD cards.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.