1

I am using raspberry pi 4 as a gateway to my esp8266 devices. I have connected ethernet to pi for internet connection. It works fine. I want to generate ntp time in my esp8266 device. When I connect devices to direct wifi they are getting right time. But when I connect them to pi gateway they are getting date 01.01.1970 . How to get current date from pi gateway ?

  • Is the RasPi connected to the internet? Does esp8266 have wired and WiFi interfaces? – Ingo Sep 8 at 17:52
3

Recent Raspberry Pi OS includes systemd-timesyncd as the NTP client. Unfortunately for you, systemd-timesyncd does not implement the server functionality, so it cannot provide network time to clients downstream.

You'll have to set up a full-featured NTP server such as ntp, openntpd or chrony (you may disable systemd-timesyncd, but you don't have to: it is polite enough not to interfere). Or, if you have any of these set up already, you need to configure them to act as a server.

| improve this answer | |
  • 1
    I think your answer is correct, which is to say I interpret the question as you do. However, I do suggest one correction: There is no need to disable systemd-timesyncd - it politely "steps aside" if another NTP server is running. See this old-ish answer, or review systemctl cat systemd-timesyncd – Seamus Sep 9 at 21:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.