1

for the last few days I have been trying to connect my raspberry pi 3B to an enterprise wifi network with little success. My wpa_supplicant.conf looks like:

network={
        ssid="(My Network SSID)"
        key_mgmt=WPA-EAP
        identity="My_Identity"
        password="My_Password"
        phase2="auth=MSCHAPV2"
}

I also downgraded my wpasupplicant from 2.7 to 2.4 as I read somewhere that 2.7 had issues with wpa2 enterprise networks. Now when I run wpa_supplicant -v it says wpa_supplicant v2.4. I think it is managing to connect to my network and dns works but I still don't have an internet connection because when I try to do something like ping google.com it shows an ip but I get 100% packet loss.
If I manually terminate wpasupplicant and restart it with:

wpa_supplicant -Dnl80211 -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf

I get the following:

Successfully initialized wpa_supplicant
wlan0: Trying to associate with SSID '(My Network SSID)'
wlan0: Associated with (MAC Address of nearest AP)
wlan0: CTRL-EVENT-EAP-STARTED EAP authentication started
p2p-dev-wlan0: CTRL-EVENT-REGDOM-CHANGE init=COUNTRY_IE type=COUNTRY alpha2=GB
wlan0: CTRL-EVENT-EAP-PROPOSED-METHOD vendor=0 method=25
wlan0: CTRL-EVENT-EAP-METHOD EAP vendor 0 method 25 (PEAP) selected
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=2 subject='/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./CN=Go Daddy Root Certificate Authority - G2' hash=(A Hash)
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=1 subject='/C=US/ST=Arizona/L=Scottsdale/O=GoDaddy.com, Inc./OU=http://certs.godaddy.com/repository//CN=Go Daddy Secure Certificate Authority - G2' hash=(A Hash)
wlan0: CTRL-EVENT-EAP-PEER-CERT depth=0 subject='/OU=Domain Control Validated/CN=(Enterprise Website)' hash=(A Hash)
wlan0: CTRL-EVENT-EAP-PEER-ALT depth=0 DNS:(Enterprise Website)
wlan0: CTRL-EVENT-EAP-PEER-ALT depth=0 DNS:(Enterprise Website)
EAP-MSCHAPV2: Authentication succeeded
EAP-TLV: TLV Result - Success - EAP-TLV/Phase2 Completed
wlan0: CTRL-EVENT-EAP-SUCCESS EAP authentication completed successfully
wlan0: WPA: Key negotiation completed with (MAC Address of nearest AP) [PTK=CCMP GTK=CCMP]
wlan0: CTRL-EVENT-CONNECTED - Connection to (MAC Address of nearest AP) [id=0 id_str=]

Furthermore running iwconfig wlan0 shows:

wlan0     IEEE 802.11  ESSID:(My Network SSID)  
          Mode:Managed  Frequency:2.412 GHz  Access Point: (MAC Address of nearest AP)   
          Bit Rate=39 Mb/s   Tx-Power=31 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:on
          Link Quality=40/70  Signal level=-70 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:8  Invalid misc:0   Missed beacon:0

When I try to use apt-get install I keep getting: Unable to fetch some archives.
Any help in fixing this issue would be greatly appreciated.

7
  • Do you get a valid IP address and gateway address? – user115418 Sep 13 '20 at 16:51
  • @Andyroo ifconfig gives lo: 127.0.0.1 and wlan0 inet: 10.108.1.193 and broadcast: 10.108.7.255 and netmask: 255.255.248.0 – Max Best Sep 13 '20 at 17:22
  • Try sudo apt update and see if it goes OK. Have you changed your sources file for updates at all? – user115418 Sep 13 '20 at 18:02
  • Doing apt-get update works fine. I changed my sources from buster to stretch for downgrading wpasupplicant but then put wpasupplicant on hold and changed the sources back to buster. Doing upgrade or apt-get install, however, says that some directories could not be retrieved. – Max Best Sep 13 '20 at 18:10
  • Directories or Packages? Its possibly the network has a block on some sites - I would get the IT team to check. – user115418 Sep 13 '20 at 20:49
1

Thank you for your answers. I never managed to properly get dhcpcd and wpasupplicant to work but I noticed that wpa2-enterprise networks works well with the ubuntu + mate environment supplied on the raspberry pi website. It looked like it was using network manager so what I did was go back to raspbian lite and run:

sudo apt install network-manager network-manager-gnome

Then:

sudo apt purge openresolv dhcpcd5

I was then able to setup my enterprise network and it connected and everything worked as wanted. I was trying to do all of this in order to then connect to a vpn subscription then create an access point so that I could connect devices such as an Alexa to the internet which do not support enterprise networks.

1
  • Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as a unsolved Post to the community and saves them/us a lot of work. – Ingo Sep 21 '20 at 19:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.