2

I enabled VNC using raspi-config in the Interfacing Options, but a VNC connection test from a client failed. I rebooted the RPI, and it failed to come on the wireless network. Disabling VNC hasn't been a successful rollback, sadly. Any ideas how to fix it please? Wifi was working fine for months.

If I check wifi in raspi-config it says: no wireless interface found

If I use IP LINK SHOW, it shows interfaces for loopback, ETH0, and docker0.

If I do a refresh install on a new SD card, the wireless is fine.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=GB

network={
        ssid="mywifi"
        psk="mywifipassword"
        key_mgmt=WPA-PSK

}
  • What did you set in raspi-config for the WiFi? Can you put you wpa_supplicat.conf in the question please (hide the password) using code blocks. If your SSID hidden? If so, unhide it as it is not a security feature (part of the link up transmits the SSID in plain text). – user115418 Sep 13 '20 at 13:37
  • No, the SSID is not hidden, I didn't change anything, other than whether VNC was enabled or not, via raspi-config. ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 country=GB network={ ssid="mywifi" psk="mywifipassword" key_mgmt=WPA-PSK } – Peter Schofield Sep 13 '20 at 13:48
  • Maybe worth resetting the router if it's a generic home one. They are not the greatest of free things. Note sure if it's copy / paste but you have a blank line before the closing brace '}' try removing that and rebooting the Pi – user115418 Sep 13 '20 at 15:32
  • Thanks for the suggestions. Rebooting the router didn't help the raspberry PI, but thanks for the suggestion. The brace issue was a copy-and-paste error. – Peter Schofield Sep 14 '20 at 19:49
3

Enabling VNC shouldn't touch your WiFi configuration. I suggest your WiFi interface disappeared for some other reason. Now that you have a fresh install, try going ahead with that.

Aside: if your original install had a lot of customisation making it problematic to start again from a fresh install, consider using puppet to configure your system in a repeatable manner.

This is what raspi-config does when you enable VNC:

apt-get install realvnc-vnc-server
systemctl enable vncserver-x11-serviced.service
systemctl start vncserver-x11-serviced.service

You can try those commands from your fresh install to see if they break your WiFi (but I expect they won't).

Try rebooting your original install and look at the new kernel messages in /var/log/kern.log. A missing WiFi interface is the responsibility of the kernel and kernel modules. The Raspberry Pi 4 WiFi should "just work". If hardware is detected and the necessary modules can't be loaded, there should be error messages in the kernel log.

  • Thanks for the suggestion. I didn't see anything in the kernel log, so I tried grepping for keywords like fail or disable or error. Matches were simple-framebuffer and the enet clock, and PCI bus fast back to back transfers. – Peter Schofield Sep 14 '20 at 19:51
  • Just came across this question, which has a link to an article about hi-res and wifi issues. though it looks like I am configured for the default lo-res: raspberrypi.stackexchange.com/questions/116380/… – Peter Schofield Sep 14 '20 at 20:39
  • O - that's not good... – user115418 Sep 14 '20 at 21:08
0

Not sure this is your case - and this post is not active so far - but here wifi was stuck deactivated because .... of an external HDD on one of the USB 3 port... Pretty weird, but just unplugging the HDD enabled the WiFi instantly ! I tried another cable (to the HDD) and this works too (but not all my cables do !).

  • 1
    Two thoughts - 1 a power issue where the HDD was dropping the voltage / current and impacting the Pi. 2 - possible earth issue on the USB ports. My guess is number 1 – user115418 Dec 28 '20 at 0:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.