0

I had this issue previously on my pi 4: Raspberry pi 4b: failed to connect to network
which I thought I resolved using a workaround BUT

Recently when I used my pi for ~1hr ( with network connected through wifi ) than I rebooted it the connection dropped!! I rebooted multiple time but connection failed!

I bought my pi ~1 month ago from official vendor. I have only browsed youtube on my pi until now.

Here's my main issue right now:
Now I have to keep my wifi adapter connected to my pi always for network. If I boot pi without adapter it won't connect to wifi. with adapter too it takes 5 min after boot to connect to network. And after using it for more than 20 min and than rebooting will disconnect the network than. In order to get it back running I have to shut it down and wait for 10 - 15 min before booting it back.

I need to know asap weather my pi is defected so that I can replace it or file a complaint regarding the same.

  • What WiFi adapter do you use and why? The Raspberry Pi 4B has an on-board WiFi chip. There is no need use an adapter for WiFi. – Ingo 2 days ago
  • @Ingo I bought this adapter ~3 yrs ago for my PC. In the above link I think I have mentioned why I used it. basically when I used the pi for 1st time onboard wifi worked but after than it din't work. I urgently needed internet so I connected this adapter which was in my PC, and it started working. Than I did not bothered to remove it and kept using as is. One day someone unplugged the adapter, and when I plugged it back network was not working! So here I am looking for solutions. Currently answer posted by me below is working! If you have a better approach, inform me pls! – luckyCasualGuy 2 days ago
0

According to: This post! dated: 2019-11-27 13:23

It appears that pi 4, until an update is released, will have wifi connecting problems on higher resolutions. you need to bootup your pi at lower resolutions (for me it worked at 640 * 400). After booting you can switch to high resolution!.
I tried other resolutions too but for me 640 * 400 only works!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.