0

I followed this tutorial to setup my Raspberry Pi 3 B+ as a wireless access point. I have gotten to the point where the Pi broadcasts an SSID, but as soon as a client tries to connect to that SSID, my entire Pi crashes and needs to be restarted. The connection always fails once the Pi crashes. I have re-flashed the Pi and started over, copying and pasting as much as possible from the tutorial to ensure I'm doing absolutely everything as instructed. I can't figure out what I'm doing wrong or what's causing the Pi to die every time. Any insight would be greatly appreciated.

Here's the output from running hostapd to the Pi crashing:

$ sudo hostapd /etc/hostapd/hostapd.conf
  Configuration file: /etc/hostapd/hostapd.conf
  Using interface wlan0 with hwaddr 74:da:38:ef:f2:d6 and ssid "TestServer"
  wlan0: interface state UNINITIALIZED->ENABLED
  wlan0: AP-ENABLED
New contributor
MitchTJones is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
2

It seems that that one of hundred tutorials you used is somewhat outdated. You should use the tutorial given on the official Raspberry Pi site: Setting up a Raspberry Pi as a routed wireless access point, as already suggested by @Andyroo in his answer.

If you have problems with hostapd or need a some more sophisticated setup, you may have a look at Setting up a Raspberry Pi as an access point - the easy way, which does not need additional helper programs like hostapd and dnsmasq.

| improve this answer | |
1

I expect this answer to be downvoted but here goes.

Stop following old articles that are based on old operating systems. Stretch was replaced by Buster well over a year ago.

Follow the new instructions [here][1] (As of Sept 2020).

Core steps I take BEFORE setting this up:

  • Download a new LITE version of the OS
  • Check SHA matches
  • Burn with Etcher and verify card OK with Etcher option
  • Add SSH file
  • Connect Pi via Ethernet and boot
  • Use sudo Raspi-config to set Pi name, Wifi Country, Expand Disk
  • Reboot Pi (soft reboot)
  • Run sudo apt update still on Ethernet
  • Run sudo apt -y full-upgrade
  • Run sudo apr -y autoremove
  • Power off

I then set up static IP addresses on the home router as needed (Ethernet and / or WiFi). Decide who is going to control IP addresses (only ONE device does this per sub-net) Decide what the sub-net ranges and settings are Check router / other devices are OK for IP addresses currently in use

Then I follow the instructions.

Wonder if you have an IP clash where something is issuing the IP of the WiFi / Ethernet / Bridge? Make sure that are not occupied or can be issued by any DHCP service currently running. [1]: https://www.raspberrypi.org/documentation/configuration/wireless/access-point-routed.md

| improve this answer | |
  • Thanks for responding! That was the first article I tried, and I get the exact same result. The article I listed is the 4th one I've tried; each time, I re-flash the Pi and start from scratch. Each time I get the same error. – MitchTJones 2 days ago
  • Baffled - I've had the Pi versions (both same subnet and different ones) with no issues. I've put a few more notes in the answer. – Andyroo 2 days ago

Your Answer

MitchTJones is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.