I am using Raspberry Pi 4 for experiments with Docker. The problem is, sometimes I need to copy-paste information from the internet, but my server has no UI.

I tried the ubuntu-desktop package which made the system slow to the extent that it was unusable. I tried sway, but it doesn't start at all with this error.

Question: How to setup a simple, workable GUI on Raspberry PI 4 running Ubuntu Server 20.20?

Basically, I only need to open browser and terminal. That's it.

  • try a text based web browser like Lynx
    – jsotola
    Sep 21, 2020 at 8:15

3 Answers 3


There is no need for a desktop to copy and past information to a Ubuntu Server. SSH and and a SSH client, wget and scp can perform this tasks perfectly from the command line.

  • ssh is a remote terminal into your server.
  • wget fetch files from an http(s), ftp source.
  • scp copy a file to your Ubuntu server from your local PC.

Ref.:ssh , wget , scp

  • Well, it is a test machine and I don't want to expose its ssh port to the network. It is not that easy to use wget or curl for modern web sites. Just try querying for instance this documentation docs.docker.com/engine/install/ubuntu Sep 21, 2020 at 6:55
  • 3
    Take a look at how to create a ssh login with "SSH Key-Based Authentication" and limit what have access to ssh, that is a god protection, and its a BAD practice to have a desktop on a server (even a test server). Sep 21, 2020 at 7:00

"How to setup a simple, workable GUI on Raspberry PI 4 running Ubuntu Server 20.20"

Simple answer - you can't.

The server works well enough (if not spectacularly) and it IS POSSIBLE to install a GUI but this is not endorsed by Canonical and there are none specifically targeted at the Pi.

apt offers a few alternatives. I tried, but can't recommend any.

If you do you will need to change networking.

  • Interesting answer - I did notice they are saying you can install 3 desktops (Ubuntu, kubuntu, lubuntu) ubuntu.com/download/raspberry-pi/… (may start to download an image) - are they all bad or have they now been tweaked for the Pi?
    – user115418
    Sep 21, 2020 at 20:01

I am working on a Raspberry Pi4 with Ubuntu Desktop/UI:

Linux ubuntu 5.4.0-1080-raspi #91-Ubuntu SMP PREEMPT Thu Jan 19 09:35:03 UTC 2023 aarch64 aarch64 aarch64 GNU/Linux
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 20.04.5 LTS
Release:    20.04
Codename:   focal

I was unable to install desktop directly from the .iso, but installed server .iso first, and afterwards packages needed to run desktop.

There is a bit ui lag on my 4k screen, but i am also possible to work through freerdp to a remote windows pc - without further lagging :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.