1

When the Raspberry Pi boots, a bootloader info screen (see image below) shows up for about 1 second. I was wondering how I would go about disabling this screen from appearing.

I have tried a couple of guides on how to achieve a quiet boot but seems like this screen shows up no matter what the contents of my cmdline.txt and config.txt files are.

My current file contents are:

/boot/cmdline.txt

splash quiet console=serial0,115200 console=ttyAMA0,115200 console=tty3 loglevel=3 logo.nologo root=PARTUUID=c356f926-02 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait

/boot/config.txt

disable_splash=1

Photo of screen

5
  • There's no point in anything involving cmdline.txt because that is for the linux kernel.
    – goldilocks
    Commented Sep 23, 2020 at 14:28
  • 1
    I recommended you should not remove it because pi is a development board and things can go wrong. Commented Sep 23, 2020 at 15:11
  • 1
    Your screen shot shows a system that hasn't been able to boot from SDcard or USB device. There's no way to suppress that in just the same way that there's no way to use a system in that state.
    – Dougie
    Commented Sep 23, 2020 at 15:31
  • The system does boot after 1 second and works as expected though. Is it possible that the SD card has been corrupted or something similar? Would a corrupt SD card cause this?
    – mhmmx
    Commented Sep 23, 2020 at 17:15
  • Yea, something is strange here - I have not seen this screen before. I get the white "Press shift for recovery" screen and then the boot sequence starts (silent mode disabled).
    – PMF
    Commented Sep 23, 2020 at 18:30

2 Answers 2

2

I was able to solve this much more easily by calling:

sudo -E rpi-eeprom-config --edit

Adding:

DISABLE_HDMI=1

and Save

For me that works fine.

0

From the Pi Website...

The bootloader EEPROM image contains an embedded configuration file to define the boot behaviour (e.g. selecting between SD, network and USB boot).

https://www.raspberrypi.org/documentation/hardware/raspberrypi/booteeprom.md


That splash screen can only be disabled in the config.txt located in the Bootloader in the EEPROM.

Here's the Steps i used (explained as simply as i can) to disable it.

STEP1: log into your Raspberry Pi via Terminal SSH (i used PuTTy) default login is pi .. password is raspberry

STEP2: type (or copy'n'paste) this .. vcgencmd bootloader_version to display the version and date of the bootloader you are using. eg. mine is Sep 3 2020 13:11:43

STEP3: type (or copy'n'paste) this (if your bootloader date is different to mine, then you'll need to change pieeprom-2020-09-03.bin to the date of your bootloader. format is YYYY/MM/DD)

cp /lib/firmware/raspberrypi/bootloader/beta/pieeprom-2020-09-03.bin pieeprom.bin

STEP4: type (or copy'n'paste) this .. rpi-eeprom-config pieeprom.bin > config.txt

STEP5: type (or copy'n'paste) this .. cat config.txt

STEP6: you should see something like this below ... and what you need to change is DISABLE_HDMI=0 to DISABLE_HDMI=1

[all]
BOOT_UART=0
WAKE_ON_GPIO=1
POWER_OFF_ON_HALT=0
DHCP_TIMEOUT=45000
DHCP_REQ_TIMEOUT=4000
TFTP_FILE_TIMEOUT=30000
ENABLE_SELF_UPDATE=1
DISABLE_HDMI=0
BOOT_ORDER=0xf41

STEP7: type (or copy'n'paste) this .. sudo nano config.txt

STEP8: edit DISABLE_HDMI=0 to DISABLE_HDMI=1 .. then on your keyboard press CTRL O, then ENTER and then CTRL X

STEP9: type (or copy'n'paste) this .. rpi-eeprom-config --out pieeprom-out.bin --config config.txt pieeprom.bin

STEP10: type (or copy'n'paste) this .. sudo rpi-eeprom-update -d -f ./pieeprom-out.bin

STEP11: You will now see the following message

BCM2711 detected Dedicated VL805 EEPROM detected *** INSTALLING ./pieeprom-out.bin *** BOOTFS /boot EEPROM update pending. Please reboot to apply the update.

STEP12: Last Step .. type sudo reboot

When the Raspberry Pi reboots the bootloader Splashscreen is gone.

To re-enable the splashscreen for diagnostics .. just redo all the steps above changing DISABLE_HDMI=1 back to DISABLE_HDMI=0

2
  • On a fully up to date system you can now edit the config with sudo -E rpi-eeprom-config --edit. Documented on the page you link to.
    – Dirk
    Commented Nov 12, 2020 at 18:42
  • tried that, didn't work (i'm using Retropie 4.7) all i get is .... pi@retropie:/ $ sudo -E rpi-eeprom-config --edit usage: rpi-eeprom-config [-h] [--config CONFIG] [--out OUT] eeprom rpi-eeprom-config: error: too few arguments ................ but the guide i posted above, Does work.
    – Phil Smith
    Commented Nov 12, 2020 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.