2

Good Day

I'm looking for a good single board computer that can run a speed-test and actually achieve gigabit. We have gigabit service from Rogers, but it hasn't worked properly for months and I'm getting tired of running speed-tests. I know people have used Raspberry Pi's / Alternative boards for automated speed test fixtures, but can these actually get up to gigabit?

If they can, what boards are recommended?

Thanks

5
  • I can get 1 gigabit/sec transfer via my router using a local PC to an Rpi 4 so if the gigabit is there, I should think the Pi can take it. Earlier Pis did not have Gigabit ethernet. Sep 24 '20 at 20:34
  • Alright, that's good enough for me.
    – Docmur
    Sep 24 '20 at 20:46
  • To be clearer, my ISP cable internet speed is 200 megabits and I can max that out on the Pi 4 just like I can with the other computers connected to my cable modem/router. Also I use the Pi as a NAS - I have 2 USB3 hard disks connected to the Pi which are shared on the LAN using Samba, and I can get 100-105 megabytes/sec copy speed to and from these shares which means I am maxing out the Gigabit ethernet connection. Sep 24 '20 at 21:57
  • It's unlikely that your isp will accept your figures anyway. Check your T&Cs and there will be so many exclusions as to maximum rate that any figure you give will be an argument point for a discounted break not breach of contract. As you will be checking vs a general service the first out is that there service is not the isp one so it's the other network not theirs. Then you get into the kit is not certified (inc any switches / cables / interference) and then out comes the docs that will state max possible and over a given time - been there both private and corporate.
    – user115418
    Sep 24 '20 at 21:58
  • Also, there are a lot of factors outside the ISP's control. You would only get the maximum advertised down speed from a host on the web if the server, the host's connection to the web, and all the route to your home connection support that speed. I have 200 megabit service in the UK and I can get that at 2 AM from a Netherlands based binary Usenet server, but I won't get that at 8 PM on a weekday. Sep 25 '20 at 7:44
6

Yes, the Raspberry Pi 4B can handle 1 GBit transfer rate on the wired connection. Other versions of the Raspberry Pi cannot support it because of limitations by the hardware.

I have just tested it with iperf on my network with just one Gbit switch between the testing Laptop and the tested Raspberry Pi. Here are the results on the RasPi:

rpi ~$ iperf -s
------------------------------------------------------------
Server listening on TCP port 5001
TCP window size:  128 KByte (default)
------------------------------------------------------------
[  4] local 192.168.50.60 port 5001 connected with 192.168.50.57 port 39636
[ ID] Interval       Transfer     Bandwidth
[  4]  0.0-30.0 sec  2.99 GBytes   856 Mbits/sec

and on the Laptop:

rpi ~$ iperf --time 30 --client raspberrypi.local
------------------------------------------------------------
Client connecting to raspberrypi.local, TCP port 5001
TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.50.57 port 39636 connected with 192.168.50.60 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-30.0 sec  2.99 GBytes   857 Mbits/sec

As you can see I get a Bandwidth of 856 Mbits/sec. That is what you get with Gbit support because you always have an overhead from the ethernet protocol, so you will never reach exactly 1 Gbit.

9
  • Are you guys talking about RJ45 socket? 😯 I thought they are either 100mb or 1gb (servers only)
    – Iman
    Sep 25 '20 at 14:40
  • 1
    @Iman The port on the RasPis you plug in an ethernet cable for wired connections is a RJ45 socket as usual. Only the Raspberry Pi 4B can handle full 1 Gbit. The RPi 3B+ has a crippled Gbit support with max. 300 Mbit, due to limits of the USB bus. All other RasPis only have 100 Mbit.
    – Ingo
    Sep 25 '20 at 14:48
  • 1
    @Iman - on any device, an RJ45 socket supports whatever the hardware behind it supports. My router, switch, desktop PC, laptop PC and Rpi 4 all have RJ45, and all support gigabit ethernet. Sep 25 '20 at 18:18
  • Thanks micheal and ingo. I am really surprised. (for some reason mentioning with @ did not work)
    – Iman
    Sep 26 '20 at 0:54
  • @Iman You can mention only one person and you cannot mention me, because it is my answer and I always see the comments.
    – Ingo
    Sep 26 '20 at 8:00
0

I run a Rpi4 4gig. as my home router on Comcast. I have a USB dongle as my second Ethernet port (for inside the home 192.168.x.x network). The dongle is plugged into a fast USB port.

I run a MTU of 1412 for all my Internal devices. (See "man pppoe" for the reason).

My tranmission speed through two switches into the dongle Ethernet was:

TCP window size: 85.0 KByte (default)
------------------------------------------------------------
[  3] local 192.168.x00.11 port 52254 connected with 192.168.x00.1 port 5001
[ ID] Interval       Transfer     Bandwidth
[  3]  0.0-30.0 sec  1.66 GBytes   475 Mbits/sec

More than adequate for my purposes. This doesn't answer your question about the RJ-45. The dongle does have an RJ-45 on one end of it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.