1

I have two monitors connected to a RPi 4B rev 1.4 running Raspbian 10. When I boot, both monitors are mirrored, so I go to Preferences > Screen Configuration and set the monitors up how I want (side-by-side). However, when I reboot again, the monitors are back to mirrored mode.

How can I get these settings to persist?

I have already confirmed that in /boot/config.txt, max_framebuffers=2 is set, per some other SE posts.

This is particularly strange because I have gotten this to work with a different pair of monitors in the past, with the same Raspberry Pi, and no software changes in the ensuing time period. The old monitors were one HDMI & one DVI (through an HDMI-to-DVI cable); the new monitors are both HDMI. Perhaps the HDMI monitors are talking back to the Pi and somehow requesting to be mirrored?

If this is helpful, per xrandr --listmonitors my two monitors are:

Monitors: 2
 0: +*HDMI-1 1920/476x1080/268+1920+0  HDMI-1
 1: +HDMI-2 1920/477x1080/268+0+0  HDMI-2

and tvservice -l says:

2 attached device(s), display ID's are : 
Display Number 2, type HDMI 0
Display Number 7, type HDMI 1

This is after I have changed the monitors to be how I want them. After a reboot, tvservice says the same thing, but xrandr says

Monitors: 2
 0: +*HDMI-1 1920/476x1080/268+0+0  HDMI-1
 1: +HDMI-2 1920/477x1080/268+0+0  HDMI-2

however this is the same besides the offset on HDMI-1.

Is the best thing to do just to put an xrandr command in some rc or boot file? Or is there a way I can actually get these settings to persist on a per-monitor basis, as I'd expect?

Thanks!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.