0

I mounted an Ext3 USB drive using fstab. It works, but I have one issue. Sometimes when I turn on the system, the drive is not visible. I can not find it in mnt, media or in the desktop.

It does not appear, even if I call sudo fdisk -l. But if I unplug it, I get this alert:

Drive was removed without ejecting

If I uncomment the record from fstab and reboot, it's still not visible. The mount command does nothing. There is no /dev/sda1 or /dev/sda2

I turned it off, unplugged the drive, and tested it with my PC, and it worked. Then I plugged it back to the PI, and it was still not visible.

I tried the disk on a different USB3 port, but still nothing.

Then I plugged in an other USB drive, and then replaced it with my original drive, and finally it was visible again.

What could go wrong?


Note: Please do not close it as a duplicate. I've found the other similar questions, but those answers did not work, as I explained it in my question. My problem is different.

  • 2
    How would we know which questions you found and what you have tried so far? Telling us what you tried could avoid not-working suggestions... Did you e.g. check for (error) messages in the logs? Have you checked the most common problem: power issues? – Dirk Sep 28 at 18:51
  • 2
    Can you also add the fstab line and output of lsusb? – Andyroo Sep 28 at 19:54
  • 1
    The Drive was removed without ejecting suggests it was mounted (other place than /mnt or /media perhaps? Can you find the drive with mount or df? – Ljm Dullaart Sep 29 at 13:53
  • ... or with lsblk? – Ingo Sep 30 at 11:03
2

You're less likely to get a good answer without providing relevant information in your question. As it's written now - your question is only gibberish.

There are a variety of tools available for reporting the status of drives and filesystems - drives that are mounted, and drives that are connected-but-unmounted. There is also your /etc/fstab - which you say "works", but then say it doesn't?

Here's what you should do if you want any help, or an answer:

  1. edit your question to add the output of cat /etc/fstab

  2. read man lsblk, then edit your question to add the output from this:

    $ lsblk --fs
    
  3. Read How to List Mounted Drives on Linux - or something equivalent. As a minimum, edit your question to add the output from this:

    $ findmnt -t ext3
    
| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.