1

I can't hear any sounds from my Pi 4. I tried all speaker tests, I've changed my sound output to HDMI1 which I use, and tried all suggestions. The sound just disappeared, without any warning at all. I don't understand what happened. Anyone has that same problem? And any solutions?

7
  • 2
    Did the sound ever work? Any reason you can’t just re-flash your sd card? – CoderMike Oct 1 '20 at 10:00
  • 2
    If you already tried all suggestions then we also cannot help. Your Raspberry Pi must be broken. – Ingo Oct 1 '20 at 20:15
  • Even with the tests in tinkerboy.xyz/raspberry-pi-test-sound-output you did not hear a thing? I would try at least to insert in AV port an audio jack and perform the tests on that link – RCaetano Oct 5 '20 at 11:15
  • Also, I was able to hear sounds of downloaded files but not in Chromium, then I found this askubuntu.com/questions/284202/chromium-doesnt-play-sound and it solved the issue ;) – RCaetano Oct 5 '20 at 11:27
  • @CoderMike whats an sd card? – Jasmine Wong Oct 8 '20 at 7:17
1

I just found out that it was all a misunderstanding and that the sound was controlled by another device. All I had to do was turn up the knob. Can someone tell me how to close this?

1
  • Just click on the check mark next to this answer. – Dmitry Grigoryev Jan 26 at 9:37
0

Can you try this script? I found it somewhere on the here, but it's been a long time and I don't remember where it is. I had this problem too, you should just need to execute this once.

sudo modprobe snd_bcmm2835

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.