0

I went to an authorized reseller, but they gave me this charger for my Raspberry Pi 3B. I used Etcher to write the August 2020 version of RPi OS to the SD card and it boots fine. However, during boot it shows the yellow lightning icon (it would've been great if it showed the value of the voltage along with the icon). I've seen the FAQ and answers like this, this and this.
One of the comments on this page encourages the user to try running the Pi anyway.

What I'm currently connecting to the Pi when it boots:

  • HDMI cable for the monitor.
  • Ordinary 104 key keyboard.
  • Ordinary laptop mouse.

Question:
Before going to the store to replace the charger with the official RPi power supply adapter, I need to check if a 2.1W speaker and a USB mic will work with my Pi. After the Pi boots up, if I disconnect the keyboard and plug in the speaker to the 3.5mm jack and the USB port and I connect the USB microphone to another USB port, would it be safe? A friend said USB ports have an auto-shutoff for safety. Is it safe to try it this way? I assume the SD card can get corrupted only if there is low voltage during startup or shutdown, correct?

  • The worst that could happen with your setup is probably an unexpected reboot and MicroSD card corruption. You could also just SSH or VNC into the Pi, so you can get rid of the keyboard and mouse. (SSH is less resource-intensive, and so will have a less likely chance of rebooting randomly than VNC.) – Unsigned_Arduino Oct 2 at 11:56
  • 1
    Does this answer your question? Raspberry Pi Power Limitations – Milliways Oct 2 at 12:20
  • Most annoying thing I found on a Pi 3B and Zero was the WiFi would disconnect randomly. Took me a few weeks till I swapped the charger for an official power supply and cured my woes in one step. – Andyroo Oct 2 at 15:21
  • I tried the WiFi. The moment I switch it on, I get a low voltage warning. Also tried the speaker (for speaker and mic also I got low voltage warnings. I don't understand why the authorized resellers are selling cheap chargers instead of the official adapter). The 3.5mm jack didn't seem to fit well and I couldn't hear any of the music I was playing. Couldn't get any inputs from the mic either, as Audacity said the device could not be detected. I guess the drivers aren't present because I'm using the 1.1GB version of RPi OS. I'll download the full version and try. – Nav Oct 3 at 5:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.