I used the Edimax wifi dongle on the Raspberry Pi, by using the sudo iwlist wlan0 scan, I can get a list of wireless networks, and I found my wireless network information, such as

Protocol: IEEE 802.11bgn Mode :Master Encryption key :on IE: IEEE 802.11I/WPA2 version 1 Group Cipher : CCMP Pairwise Ciphers : CCMP Authentication suites :PSK

Then I tried two ways to change the WLAN configuration, 1. go to interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
###iface wlan0 inet manual
###wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface wlan0 inet dhcp
wpa-ssid **MYSSID**
wpa-psk  **MYPSK**

then I saved the file, and reboot, check the ifconfig, still can't find the IP on WLAN0
I tried the second way. go to interfaces

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet dhcp
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

then go to wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
network={
   ssid=**MYSSID**
   psk= **MYPSK**
   # Protocol type can be: RSN (for WP2) and WPA (for WPA1)
   proto=WPA
   key_mgmt=WPA-PSK 
   pairwise=CCMP
   group = CCMP
   auth_alg=OPEN
   scan_ssid=1
}

then save it , reboot it, ifconfig , still don't work

I can' t figure out what is wrong with it now

the WIFI dong only give blue light when I command : iwlist wlan0 scan

  • I see you changed wireless0 to wlan0. was that just a typing error? – 11chubby11 Nov 16 '13 at 2:59
  • yes,sorry, it is a typing error. I prefer to work on the first approach, but still don't work – user824624 Nov 16 '13 at 3:02

first ,check whether lsmod lists your 8192cu.ko module. If not compile it for the specific kernel version and insert it.

Apply a sudo dhclient wlan0 ( usually lack of ip address is because of the error in wpa_supplicant.conf file ) This usually fixes mine..

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.