0

I'm trying to use Fedora Server 32 on my Raspberry Pi 3 Model B, using the procedure documented here. Everything goes pretty well, up until the point where I have the system set up and I try to connect to WiFi. The FAQ listing here indicates "Wifi on the Raspberry Pi 3-series devices works out of the box with Fedora." But, when I try to list available WiFi networks using nmcli device wifi list, I get nothing. So, I just run nmcli device, and it shows me that the interface wlan0 exists, but is listed as "unavailable". I've tried everything I can think of, and I haven't been able to get the WiFi device to become "available". Plus, the FAQ doesn't indicate anything else that has to be done (given that it says it "works out of the box"...).

I've searched around for other problems like this on the Raspberry Pi using Fedora, but everything else I've found that "looks" like this has to do with missing Broadcom firmware for the WiFi interface that could not be distributed with previous versions of Fedora; as of Fedora 32 (at least), that problem seems to be solved, because running dmesg shows me that the Broadcom firmware for the WiFi interface is present, and is loaded.

The only specific issue I've seen with my setup is that, when the system boots, I do see a kernel message scroll by that says "Undervoltage detected". But the system otherwise seems to be running just fine. Is it possible that an undervoltage condition could exist in such a way that everything in the system works, except the WiFi interface? I know that the label on the box that my power supply came in said that it can supply "2.4A" (which is just a tiny bit under the 2.5A that everything I have found says that Raspberry Pi 3 wants) - and I also know that sometimes the labels on the box don't actually tell the truth...

2
  • 2
    Does it work if you run RaspiOS? How about lifting /lib/firmware/brcm from a RaspiOS system on to your Fedora system.
    – Dougie
    Oct 9, 2020 at 10:45
  • I have not tried it yet with RaspiOS, that's my next step (later this evening, probably...)
    – patbarron
    Oct 9, 2020 at 15:59

2 Answers 2

1

For those with wired connections you can just do

dnf install wpa_supplicant

This was fixed issues for me on Fedora Server 33 after a reboot.

1
  • In my case, I had no wired connection available, so this problem was a showstopper for me until I figured on what the problem was and manually downloaded the wpa_supplicant RPM on another computer, and copied it over via a USB flash drive and installed it. Why Fedora Server would package NetworkManger-wifi but not wpa_supplicant is still a mystery to me...
    – patbarron
    Nov 30, 2020 at 0:25
0

I was (finally) able to solve this...

I thought the problem might be with my power supply because of that undervoltage warning, so I put a USB voltage/current meter on my power supply, and saw that it was only delivering 4.9 volts, so the undervoltage warning was legit. I got a better power supply, and that problem went away. But, this didn't change my WiFi issue at all...

After more searching around, I stumbled across this Fedora bug, which clued me into the fact that, for whatever reason, wpa_supplicant is not packaged in Fedora Server 32. That was the cause of my WiFi being unavailable. I guess they figure that a "server" isn't going to be using WiFi. Or, maybe it was just left out inadvertently, since NetworkManager-wifi is packaged in Fedora Server 32 (and if so, it's disappointing this bug still exists in Fedora 32 since it was filed against Fedora 31 Beta...).

I thought about trying to see if I could work around this by using low-level iw commands. But I thought better of it, and instead downloaded the wpa_supplicant package from the Fedora 32 "Everything" repository for aarch64 on to another computer, copied it on to a USB flash drive, then mounted that on the Raspberry Pi and used rpm -i to install it. Then I started the service using systemctl start wpa_supplicant.service. And then, like magic, my WiFi interface suddenly became available, nmcli device wifi list showed the available WiFi networks, and I was able to use nmcli device wifi connect to get connected. Problem solved.

1
  • 1
    FWIW ... Fedora Server 33 was released last week, and it also does not package wpa_supplicant, so it will also have this problem. The workaround is the same - grab the wpa_supplicant package from the Fedora 33 "Everything" repository for aarch64, and install it.
    – patbarron
    Nov 3, 2020 at 22:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.