-2

I have a Mean Well Switching power supply 5V. I have connected 5V output to rpi's 3b+ gpio pins to power it up, but the supply is just going up/down like it has no power drain. can you recommend how to make it hold the voltage?

EDIT: photo, as requested: enter image description here enter image description here

thanks

19
  • How much power (Amps) does the power supply deliver? Make sure the current limit is set to at least 3Amps. – PMF Oct 14 '20 at 17:25
  • What is the specification of the power supply? What cables are you using to connect to the Pi? – CoderMike Oct 14 '20 at 17:26
  • it's 7A i believe. a lot.. just a reular thin cables :D – greengold Oct 14 '20 at 17:37
  • 1
    Have you got a link to the PSU? Don't use thin cables for power. – CoderMike Oct 14 '20 at 17:38
  • 2
    @greengold All the information you have added in comments should have been edited into your question. – joan Oct 14 '20 at 19:49
2

The Meanwell RD-125A power supply that you are using implements a feature called "Hiccup Mode" which is triggered when the load on the primary channel is too low. So this is expected behaviour.

Somebody on Amazon worked around this by adding a resistor as a dummy load, and wrote it up in their review, but this doesn't seem like a great idea to me.

I'd use a different power supply, or use a buck converter from the stable 12V supply (if it is stable, and not also resetting when hiccup mode kicks in) to get 5V for the Pi.

3
  • Upon close inspection the datasheet says "it is recommended that CH1 load > 15% rated current". There's a big mental leap between that statement and the observed behavior. If the issue is confirmed, I'd try to return this supply back as defective and use a different one, like you said. I have a similar no-name supply which works perfectly at any current / voltage combination within the range. – Dmitry Grigoryev Oct 15 '20 at 14:19
  • yeah that's basically right but I doesn't like the resistor idea much too. can't even buy 50W resistor here... @DmitryGrigoryev observed behaviour matches the described one: it really doesnt hold up wirh load like rpi is. >15% is way too high. what psu do you use? – greengold Oct 15 '20 at 15:00
  • @greengold 15% of the rated current (7.7A) is 1.15A. You don't need a 50W resistor to dissipate 5V*1.15A=5.7W, 5-10W will do. My PSU is hjs-480-0-48: it's adjustable in the range of 0-48V and 0-10A. They have 5V and 12V variants as well. – Dmitry Grigoryev Oct 16 '20 at 11:10

Not the answer you're looking for? Browse other questions tagged or ask your own question.