0

This topic may be misleading. Let me clarify. I need to enable HDMI on my new raspberry Pi 4 (I am a new user to pi). This is accomplished by changing one line in /boot/config.txt. This is posted in another thread.

However, it would appear that I need to login as root. The forum is circular in that it suggests I need to change /etc/ssh/sshconfig file to allow root login. BUT

I cannot change either of these files, and save the changes unless I am logged in as root. Unlike linux boxes I have used in the past (it's been a few years so you know, so maybe I am misremembering) root login on the pi is disabled by default, and the HDMI (which by the way is the ONLY video out) is also disabled by default. There does not seem to be a way to log in as root, as it is disallowed.

What to do?

Now you say "How did you set the pi up in the first place?" Which is a good question. I installed the OS a total of 11 times, until I got it right. I did this by editing the necessary config files when I installed the OS on the pi, now that it's set up, it seems to have reverted with a hashtag, commenting out the HDMI line in boot config. I have since added (remotely) software and such on my pi, and I really do not want to reinstall and spend hours on something I should have access to right now. I find it stupid that it comes out of the box like this.

3
  • 2
    This Question is predicated on a number of misconceptions. HDMI is enabled by default - there is NO NEED to change anything - it works out of the box. You CAN NOT login as root - at least by default; Raspbian has no root login, and it is NOT needed.
    – Milliways
    Oct 15, 2020 at 7:55
  • 2
    Further to this, when you do need to do things with root privileges (which I'm sure you will) you will need to use sudo (which is enabled by default for the 'pi' user). You can learn about this here: raspberrypi.org/documentation/linux/usage/root.md Oct 15, 2020 at 10:18
  • LOL.... "predicated on misconceptions". Since I first posted this, the solution has appeared on the official rasberry pi website, so there is that nugget of knowledge that I was not the only person this happened to, and it was far from an isolated case. The steps outlined in my own solution are one of several solutions now found there as well, as HDMI is not always enabled.
    – Zero Code
    Dec 28, 2021 at 9:24

3 Answers 3

1

Thanks a lot for the -1 comment on a rather simple beginners question. So helpful. As a grown up, I would have read the question, and if I thought it was stupid, I would simply move on without needed to lash out. I'm sure some people are happy I didn't do that kind of thing when I was on here before. I mean, if you don't understand differential equations, I get that. Not everybody does. Likewise, it's not as though the Pi install manual says much either, which is why I'm here.

Thanks to ROB Bicheno - SUDO was the way to go (answer at bottom). I knew there had to be a way to do this, but it was certainly hard to find. I think I came across the same thread a few hours after posting.

Milliway - I have the unit here. I have owned it for about 4 months. While what you know may be correct to a point, my HDMI was disabled by default out of the box. You can say what you want, but that's just the way it is. I came across quite a lot of the same information from other purchasers in my quest for answers. You can go ahead and argue me and start ranting, but I can't change facts. See the below graphic with the necessary lines with comments removed by me, fixing the problem.

Using the sudo command I was able to go in and ENABLE the HDMI remotely using VNC. I may not have mentioned this, but the pi has been running for months. I unplugged it during a recent move, and when I turned it back on in the new place, the settings has reverted. This seems very Windoze-like to me and while I cannot explain why this happened, I can only take steps to fix it. (drumroll)

Answer that I was looking for, and found on my own:

Open terminal: sudo su (gets root access) nano /boot/config.txt remove # (comment marker) from necessary HDMI statement, forcing it to be "On". There are three lines that can be changed here. I commented out the two lines with arrows. The other commented lines, bracketed, were suggested elsewhere and I am not sure that would work in this case.

NOTE - the config text is also labeled which lines are necessary, if you don't have a guide.

enter image description here

Reboot

Problem solved.

So thanks to some of you, others.....carry on.

7
  • Happy to hear you got your problem fixed. I understand your reaction, but speaking from personal experience, it's usually best to ignore comments that you find caustic. One of the advantages of hanging out here is that you learn who to avoid/ignore. Trust me - you're not alone :) As a suggestion, consider editing your answer, and then selecting it (the "check mark") when you're able.
    – Seamus
    Oct 16, 2020 at 17:53
  • I read my answer, and fail to see where a bit of salt becomes "caustic"......
    – Zero Code
    Mar 16, 2021 at 14:02
  • 1
    Sorry if that wasn't clear - I was not referring to your answer or comments :)
    – Seamus
    Mar 16, 2021 at 20:41
  • FOLLOW UP: While I did solve this as above, the problem rears it's head once more when I attempted to install a PLEX server, and do something else with the Pi other than just run Pi Hole. The HDMI does not work by default!! This much is/was true, but it would seem that there may have been a waranty issue. Along the way, the FSTAB got messed up, and I could not get out of emergeny mode. Trying some commands I found here to get past that, the unit has been bricked. No HDMI signal at all. Going in the trash.
    – Zero Code
    Dec 25, 2021 at 11:42
  • 1
    Your father-in-law sounds like a smart fellow :) Good luck & congrats for solving the problem yourself.
    – Seamus
    Dec 27, 2021 at 8:39
0

If you plug in your pi's microSD card in a computer, the boot partition gets mounted as a disk and you can edit the config.txt file and reenable HDMI.

https://www.raspberrypi.org/documentation/configuration/boot_folder.md

0
0

HDMI Is enabled by default but look up how much voltage the rasperry pi 4 needs and look if your cable or powerbrick supports that voltage

1
  • You did not read the thread.... and want to argue facts. why is that? But for fun I'll answer you . My "powerbrick", or as I like to call it the "power supply" is the factory power supply that came packaged with the Pi, so I was hopeful that the manufacturer was aware of the power requirements before boxing it all up together and labelling it. But.... you never know.....
    – Zero Code
    Mar 16, 2021 at 14:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.