5

My Raspberry Pi will boot fine and I can access via SSH however when connected to HDMI it is just a black screen that appears. I notice that the display screen resolutions are alternating back and forth from 1024x768 to 640x480 and is in a loop of doing that.

Green light for SD is on and red light is on as well. I can access files and run scripts... just HDMI acting strange.

Advice is welcomed. Thank you

1
  • 1
    Have you tried running sudo raspi-config via ssh and setting a default resolution to match the monitor? It should be in advanced options - raspberrypi.org/documentation/configuration/raspi-config.md and a reboot is needed. If no go try adding hdmi_ignore_edid=0xa5000080 to config.txt and reboot again.
    – user115418
    Oct 18, 2020 at 15:42

3 Answers 3

3

I had a similar problem. My first Raspberry Pi, brand new, would not boot. Went through all the hoops of not booting RPi4B 8GB to finally trip over this link: https://github.com/raspberrypi/firmware/issues/1232

What did it for me was commenting out the dtoverlay line close to the bottom in the config.txt file

# Enable DRM VC4 V3D driver
dtoverlay=vc4-kms-v3d

to

# Enable DRM VC4 V3D driver
#dtoverlay=vc4-kms-v3d

You might have fkms instead of kms. No difference, just comment out the line you have in your config.txt

Hopefully it will work as well for you as it did for me.

1

I had the same "black screen" problem after startup and commenting out the "dtoverlay=vc4-kms-v3d" line in config.txt helped initially, but lacks access to full raspberry pi vc4 and v3d videocore acceleration. I found that the problem is not being able to load the KMS (Kernel Mode Setting) graphics driver at startup. On my Raspberry Pi installing the following three: kms++-utils and libkms++0 and python3-kms++ solved the problem. I.e. gave black screen at startup, which now could be solved by re-enabling the "dtoverlay=vc4-kms-v3d" line in config.txt, unlocking full raspberry pi vc4 and v3d videocore acelleration. Of adittional interest regarding this subject may be the following pdf: Troubleshooting KMS HDMI output by Raspberry Pi Ltd: https://pip.raspberrypi.com/categories/685-whitepapers-app-notes/documents/RP-004341-WP/Troubleshooting-KMS-HDMI-output.pdf

1
  • This seems to be the correct answer, However, I did not need to install the packages manually as this was taken care of by upgrading the packages on the system with sudo apt-get update then sudo apt-get upgrade.
    – Locke
    Feb 24 at 5:02
0

I ran into this once and found that my Raspberry Pi was 100% out of storage. From various directories I did:

du -h --max-depth=1

to find what was consuming all the storage. I found some log files which I deleted, rebooted and then I was good to go. It looks like the graphical desktop environment was requiring some temporary storage on boot up that my disk no longer had.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.