2

I am trying to watch videos with omxplayer while i'm downloading them but they always stop playing after a while. It looks like omxplayer ignores everything that was downloaded after it was started.
These are the commands i'm using:
wget www.example.com/video.mp4& omxplayer video.mp4

After a google search i found this:
https://github.com/huceke/omxplayer/issues/29

Question: Is it somehow possible to fix this issue or is there another way to do this? I would prefer not to stream the videos, because they often get interrupted.

I am sorry for my bad English, i hope you understand what i'm trying to ask.

0

This is a software bug, and has to be fixed in the source code. There is no known workaround to this issue.

The only (known) way to fix it is if you know how to program in C++. Them you could take a look at the code and attempt to fix it.

|improve this answer|||||
0

Based on this comment, You could try this command (haven't tried this, no access to the RPi atm):

wget www.example.com/video.mp4& ; cat video.mp4 | omxplayer pipe:0

This should get the play-while-downloading to work but apparently, you can't control the player after you do this as it expects commands via stdin. See linked thread for more details.

|improve this answer|||||
  • Sadly this doesn't work for me. But i installed the newest OMXPlayer build from link which seems to have a much better support for streaming videos. – puffichu Nov 30 '13 at 18:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.