Ultra-wide monitor specs: 34 inch WHFD (2560 x 1080) IPS Display (21:9) - HD 10 AMD Free sync

OS: Arch linux with Openbox (lightdm)


  1. Managed to get 2560x1080 pixels with hdmi_enable_4kp60=1 in /boot/config.txt but the default DPI is less meaning that text and icons are too small.
  2. When playing video in full screen mode with aspect ratio beyond 720p , it's not smooth as if its skipping frames but still plays, but plays smoothly when played at 720p or below.
  3. No audio over HDMI, not sure what I am missing in config.txt

Required information given below, please ask any addition info needed. Thank you in advance :)

[xxx@archlinux ~]$ xdpyinfo | grep -B2 resolution
  1. screen #0:
  2. dimensions: 2560x1080 pixels (677x286 millimeters)
  3. resolution: 96x96 dots per inch

/boot/config.txt :

  1. gpu_mem=512
  2. initramfs initramfs-linux.img followkernel
  3. kernel=kernel8.img
  4. arm_64bit=1
  5. device_tree=broadcom/bcm2711-rpi-4-b.dtb
  6. enable_gic=1
  7. dtparam=audio=on
  8. hdmi_drive=2
  9. hdmi_enable_4kp60=1
  10. disable_overscan=1

1 Answer 1


Have you attempted this? It apparently works for the 3B+. These settings go in /boot/config.txt

# uncomment to force a specific HDMI mode (this will force VGA)
hdmi_timings=2560 0 48 32 80 1080 0 7 20 12 0 0 0 52 0 159838855 7

Source: https://www.reddit.com/r/raspberry_pi/comments/aywsn2/configuration_settings_for_ultrawide_2560x1080/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.