1

I'm installing 2020-08-20-raspios-buster-armhf-lite. I normally do this headless, but I happen to have a monitor this time. It's spending a LOT of time on what appears to be an update/upgrade. Here's are the last three lines of the log.

[ OK ] Started Daily apt download activities
       Starting Daily apt upgrade and clean activities...
[ OK ] Started Daily apt upgrade and clean activities.

It never got past this point.

I don't remember versions from 2 years ago doing that. Is this new-ish? Can it be disabled for that 1st boot?

I expect update/upgrade to take a long time, but I just don't want it done until I'm ready to do it headless.

2
  • I do not understand what you mean. If I flash a RaspiOS image it first boot as usual without update/upgrade. I have to do it manual executing sudo apt update && sudo apt full-upgrade.
    – Ingo
    Oct 24 '20 at 23:17
  • @Ingo, edited question to include log.
    – MACE
    Oct 25 '20 at 13:17
1

It is the apt-daily-upgrade.service called with the apt-daily-upgrade.timer every day. I don't know why it make problems on your installation. Anyway, you don't want to run it automatically. You can disable the timer with:

rpi ~$ sudo systemctl disable apt-daily-upgrade.timer

The problem is that you can't do it because the boot get stuck on executing the service. When I look at the service with:

rpi ~$ systemctl cat apt-daily-upgrade.service
# /lib/systemd/system/apt-daily-upgrade.service
[Unit]
Description=Daily apt upgrade and clean activities
Documentation=man:apt(8)
ConditionACPower=true
After=apt-daily.service network.target network-online.target systemd-networkd.service NetworkManager.service connman.service

[Service]
Type=oneshot
ExecStartPre=-/usr/lib/apt/apt-helper wait-online
ExecStart=/usr/lib/apt/apt.systemd.daily install
KillMode=process
TimeoutStopSec=900

I see that the service will timeout (TimeoutStopSec) after 900 seconds, that are 15 minutes. So boot your RasPi and wait at least 15 min. Maybe the RasPi will continue booting and you are able to disable the timer.

If you want to disable the timer before first booting you must mount the second ext4 root partition of the CD Card on a computer with a linux operating system. Other operating systems are not able to mount ext4. If you have mounted the root partition to e.g. /mnt/ then you can disable the apt-daily-upgrade.timer by deleting a symlink:

pc ~$ sudo rm /mnt/etc/systemd/system/timers.target.wants/apt-daily-upgrade.timer
2
  • can this be done such that it is disabled during the 1st boot? thx
    – MACE
    Oct 27 '20 at 1:38
  • @MACE Yes, you can. I have updated the answer.
    – Ingo
    Oct 27 '20 at 10:57
2

For anyone else coming across this issue, you can try inputting your username to login and pressing enter. If it responds with a password prompt, just continue on logging in, and everything seems to be okay. FWIW, this was installing RaspiOS 10 'Buster' onto an old (2011) Raspberry Pi Model B Rev 2.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.