0

I'm using Raspberry Pi 3 Model B as LibreElec for Kodi. My Pi is connect on TV on HDMI. In kodi, when I select audio outputs HDMI or Jack it play sound well. But when I select Pulseaudio, it don't play any sound.

I'm following the tutorial: https://wiki.libreelec.tv/pulseaudio to use the PI as Bluetooth Audio Receiving. I could connect my Phone on Bluetooth and set it as default source.

When I do pactl info my default Sink is auto_null. In the tutorial it's write we should set the output device pactl set-default-sink alsa_output.platform-aml_m8_snd.45.analog-stereo. But I don't know how to discover this alsa_output.

When I do pactl list short sinks I only find 0 auto_null module-null-sinks.c s16le 2ch 44100Hz SUSPENDED

I also understood that I have to set my parameters on /storage/.config/pulse-daemon.conf.d/custom.conf. But for example idk how to disable load-module module-suspend-on-idle (Automatically suspend sinks/sources that become idle for too long) that is write on /etc/pulse/system.pa.

What I want is playing Kodi using Pulseaudio output device. And then use my phone to steam music by Pulseaudio[bluetooth] > kodi > TV[HDMI].

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.