4

As I've mentioned before I've run apt-get update && upgrade and my wlan0 isn't working anymore - please help. The details you've may be asking me:

uname -a

Linux pi.local 3.6.11+ #538 PREEMPT Fri Aug 30 20:42:08 BST 2013 armv6l GNU/Linux

lsusb

Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. 
Bus 001 Device 004: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 001 Device 006: ID 04fc:0801 Sunplus Technology Co., Ltd 
Bus 001 Device 007: ID 046d:c315 Logitech, Inc. Classic New Touch Keyboard

ifconfig & iwconfig

ifconfig

eth0      Link encap:Ethernet  HWaddr b8:27:eb:52:db:e1  
          inet addr:192.168.0.182  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13098 errors:0 dropped:0 overruns:0 frame:0
          TX packets:10478 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:8288713 (7.9 MiB)  TX bytes:4455841 (4.2 MiB)

iwconfig

lo        no wireless extensions.

eth0      no wireless extensions.

lsmod

Module                  Size  Used by
xt_multiport            1582  8 
iptable_filter          1493  1 
ip_tables              11490  1 iptable_filter
x_tables               16962  3 ip_tables,xt_multiport,iptable_filter
snd_bcm2835            16432  0 
snd_pcm                77728  1 snd_bcm2835
snd_seq                53482  0 
snd_timer              20110  2 snd_pcm,snd_seq
snd_seq_device          6462  1 snd_seq
snd                    58744  5 snd_bcm2835,snd_timer,snd_pcm,snd_seq,snd_seq_device
snd_page_alloc          5169  1 snd_pcm
crc_ccitt               1530  0 
rt2x00usb              11240  0 
rt2x00lib              42342  1 rt2x00usb
mac80211              273979  2 rt2x00lib,rt2x00usb
cfg80211              184390  2 mac80211,rt2x00lib
rfkill                 18298  1 cfg80211
leds_gpio               2243  0 
led_class               3570  2 leds_gpio,rt2x00lib
evdev                   9450  2 
joydev                  9356  0

I've already try to reinstall drivers as a last time - this time it didn't help :(

pi@pi / $ cat /etc/network/interfaces

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp[/quote]

and finally /etc/wpa_supplicant/wpa_supplicant.conf

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

-

#network={
#   ssid="SKYA767C"
#   psk="House!-01"
#   proto=RSN
#   key_mgmt=WPA-PSK
#   group=CCMP TKIP
#}

network={
    ssid="SKYA767C"
    psk="House!-01"
    proto=WPA
    key_mgmt=WPA-PSK
    pairwise=TKIP
    auth_alg=OPEN
}

Please note that above # are as I've try 1st and 2nd configuration and any of them didn't work. What else I need to do?

Can anyone help to fix my wlan0 interface

  • What wifi adapter do you use? – Loko Nov 19 '13 at 10:17
  • Ralink USB WiFi - details above in lsusb – Adam Nov 20 '13 at 18:32
  • please have a look at your dmesg output, the kernel probably complains about this on boot, and post it if you find something – Florian Fida Aug 23 '14 at 22:11
1

I had similar problem, but after running the following command in terminal window.

$ sudo rpi-update

then do a reboot and all is well.

I am running Raspbian wheezy, after reboot go to desktop and configure your wifi settings with wifi manager.

  • 2
    This isn't very helpful, as the user needs help getting an internet connection. rpi-update requires an internet connection to work. – RPiAwesomeness Feb 24 '14 at 16:34
  • 1
    @RPiAwesomeness they can always use eth0 to update first – PhillyNJ Jun 24 '14 at 23:22
  • @PhilVallone True, however, this answer doesn't mention that. I was just pointing out this, as the original question makes no mention of eth0 just wlan0. – RPiAwesomeness Jun 25 '14 at 0:30
0

maybe the default driver for your adapter is not usable. I got this on rtl8188cus (archlinux). I can got the adapter with lsusb and lsmod, but it did not work at all. Complile the driver and insmod should help

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.