0

I have a rpi 4b that up until this point has worked fine on my old wifi network. I've had to switch ISP from Telstra to Optus and am on a new network (old network yet to be shut off). I only access it through ssh (though I do have VNC viewer and can use a GUI).

I tried connecting my pi to the modem with an ethernet cable, but it doesn't appear at all on the network when I go to my gateway. I've connected to my pi on the old network, gone into /etc/wpa_supplicant/wpa_supplicant.conf and have:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=AU

network={
    ssid="new_network"
    psk="new-pwd"
    key_mgmt=WPA-PSK
}
network={
    ssid="old_network"
    psk="old_pwd"
    key_mgmt=WPA-PSK
}

I've tried turning the old network off before booting it, but when it boots it will never connect to the new network. I do not want to try removing the old network from the wpa_supplicant.conf file as I will then have 0 means of accessing my pi again. I have even tried going into the GUI to check the network, and despite having connected to the pi through wifi, the GUI still says 0 wireless interfaces found.

I also tried sudo raspi-config and setting the network through that menu to no avail.

I have a limited amount of time until the old network is cancelled so I am rather pressed for time.

I'm completely lost as to what to do now.

EDIT: I have located a micro hdmi : hdmi adapter that I did not believe I had. I am now able to access the pi without network access if there are any potential solutions that require it.

2
  • What is the wireless region / country set to on your new network? Are the old and new networks 2.4Ghz 5Ghz or both?
    – CoderMike
    Nov 3, 2020 at 13:15
  • My new network is AU as well. Old was 2.4GHz. I have both 2.4GHz and 5GHz new networks. I have tried both in the wpa_supplicant.conf file. Nov 3, 2020 at 13:18

1 Answer 1

0

I have inadvertently solved my own problem and I am very ashamed to say I don't know exactly what did it. I did a number of things at the same time and my pi now boots and connects to the new network just fine. Sincerest apologies for not being able to pinpoint the issue.

  • In /etc/network/interfaces, I changed iface wlan0 inet dhcp to iface wlan0 inet manual.
  • I went into sudo raspi-config and re-entered an SSID and passphrase through the network-options menu (for the ~4th time)
  • Given my newfound ability to control my rpi without an ssh connection, I removed the old network from wpa_supplicant.conf and left only the 5GHz network in there (along with another network that is my university's).
  • I then rebooted the rpi.

Interestingly enough, I am still unable to see the raspberry pi show up on my network gateway, though I can locate it with an IP scanning program and SSH into it with my laptop.

2
  • 1
    If you did anything in interfaces you broke dhcpcd networking. Delete whatever you added and connect from the networking icon on the desktop.
    – Milliways
    Nov 4, 2020 at 1:51
  • Networks have never shown up under that icon on my pi, even when I had default settings and first set up the device. I've had to do everything in wpa_supplicant from the first time I launched it. Nov 4, 2020 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.