1

I have a raspbeery pi 4 2gb

I flashed my 128gb sandisk sd with etcher on linux with ubuntu server 18 and 20 images both dont work even though it writes to the sd and says it was successful on etcher but both dont work. I also tried raspberry pi imager that also writes to the sd card but it still wont boot.

At first I thought it was the hdmi because nothing appears on the screen but I have tried 2 working hdmi cables and it doesnt boot. I tried formatting it to fat32 before flashing again.

I edited the network-config to connect to my wifi but when I run nmap -sP my other two machines on the network show up but the raspberry pi does not.

Please help me out I'm spending too much time on this one problem

It only shows one red LED light that is constant. The green led never comes on.

6
  • Which image did you flash?
    – PMF
    Nov 3 '20 at 15:39
  • ubuntu20.04.img and ubuntu18.04.img both 64bit server Nov 3 '20 at 17:12
  • Then you likely tried an AMD64 image. You need an ARM64 image. They may be harder to find. Check this tutorial: ubuntu.com/tutorials/…
    – PMF
    Nov 3 '20 at 18:22
  • thankyou, I just checked but both images are arm64. ubuntu-18.04.4-preinstalled-server-arm64+raspi4.img and ubuntu-20.04.1-preinstalled-server-arm64+raspi4.img Nov 3 '20 at 22:04
  • Also: You should try an RPiOS/Raspbian image. I suspect it will not work for you either. If not, the problem is easier to diagnose that way since it is much more widely used. If so, that is a further clue.
    – goldilocks
    Nov 4 '20 at 16:10
1

If the green led never comes on, this is the exact same thing that will happen if you plug in the power with no SD card at all in it (try that). This means at least one of three things:

  • The SD card has not been properly burned with an image. You should be able to put the card in another computer and see at least the first (very small) VFAT boot partition with a dozen or so files and a couple f directories. If you put the SD card in a system which can read ext2/3/4 filesystems (eg., a linux box), you should be able to see multiple partitions. If not, this confirms the card has not been created properly.
  • The Pi does not like the SD card for some reason, this occasionally happens; try a different card of a different make/model -- a smaller one would be better as I think this happens more often with larger cards.
  • The Pi/SD card reader is broken.

If you rule out the first two, you should be able to make a warranty claim with the distributor who sold you the Pi.

1

It wasnt getting enough power. I disconnected the fan and now it boots

1
  • Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as an unsolved Post to the community and saves them/us a lot of work.
    – Ingo
    Nov 8 '20 at 15:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.