0

First off, I have my RPi4 on a static IP set from my router. I have configured No-IP DDNS which is compatible with my ISP's modem/router so it should be updated with the correct public IP, and have changed my SSH port from 22 to another one, let's say 2222, by changing the sshd file sudo nano /etc/ssh/sshd_config. I have forwarded this port 2222 to my RPi4 static IP address, and port checking websites show that my public ip has the port 2222 open (checked locally on my RPi4). Despite all this, when using PuTTY on my Windows laptop connected to my phone's data connection wifi hotspot, which is supposed to simulate an external connection, the connection times out, not a refusal, but a timeout. Can anyone shed light on what might be going on here? FWIW, remote desktop doesn't work either and BOTH SSH and remote desktop work when I am on the same local network using the local IP addresses.

5
  • I'd suspect the phones data connection – Jaromanda X Nov 8 '20 at 7:53
  • Does not seem a Pi issue (hence my close vote) but to help I would check you are actually using phone data and not WiFi as most routers will not allow loop back to the internal lan. Then check No-IP is reporting the correct IP address for your router, then look internally and check ssh is working on the Pi port, then check the router is forwarding correctly (I use the simple web server option in Python), then check your ISP allows inbound connections - some do not. DO NOT use the web based ssh sites to check - some farm IPs for later 'use'. Set up fail2ban, security keys etc... – user115418 Nov 8 '20 at 18:22
  • Sounds like you can't reach your Pi from outside, at which point I'd double check your router and No-IP configuration. Perhaps you should set up a dummy web/ftp server to test. – Dmitry Grigoryev Nov 8 '20 at 22:26
  • Check your ssh logs to see if the sshd daemon is actually receiving the connection attempts. I agree that this is likely not a Pi related issue. – stevieb Nov 9 '20 at 0:05
  • Thank you everyone for the comments, I was an idiot and forgot to disconnect my phone from my home wifi and ended up just sharing my home wifi with my hotspot. I'm glad I got the principle behind the configuration correct though! – biotecher Nov 10 '20 at 15:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.