2

I found my old Raspberry Pi 3 B and wanted to start a new project. When I flash a new Raspberry Pi OS (32 bit) on an SD card (128 GB, bought a new one to make sure its not the SD card) via the Raspberry Pi Imager it boots up correctly, resizes the root filesystem, reboots, and seems to work.

However, when I try to run sudo apt update I get an output similar to this:

Get:1 http://archive.raspberrypi.org/debian buster InRelease [32.6 kB]
<some more links, forgive me I had to type it off the screen>
Fetched 13.4 MB in 1s (849 kB/s)
Segmentation faultsts... 0%

I also can't start the browser. This happens even at first boot so memory corruption due to pulling the plug shouldn't be the cause. Does anyone have an idea or is old age the cause and I should get a new one?

Edit: I also tried multiple operating systems like Ubuntu, all from the Raspberry Pi Imager.

6
  • Segmentation fault usually indicates a faulty program or a memory fault. No one can say from the information supplied. It could even be a faulty initial installation.
    – Milliways
    Nov 10 '20 at 7:37
  • 1
    What further Information would be helpful to you? I tried it several times with different operating systems using the Raspberry Pi Imager.
    – Dave
    Nov 10 '20 at 7:55
  • Get a bog standard 8 or 16 GB card from a known supplier. Try that.
    – joan
    Nov 10 '20 at 8:54
  • 1
    Okay, the card I used is a SanDisk. Does size matter?
    – Dave
    Nov 10 '20 at 9:11
  • Yes, it matters :) depending on the OS you're trying to install, the card size might have to be anything between 4GB and 64GB: raspberrypi.org/documentation/installation/sd-cards.md
    – David
    Nov 10 '20 at 21:19
2

A brand-new SanDisk should not present any faults, but compared to a faulty sudo apt update on a fresh installation it would still be the prime suspect.

Run your card though an SD card tester such as http://oss.digirati.com.br/f3/.

4
  • I ran the SD card check and there is no corruption.
    – Dave
    Nov 11 '20 at 6:10
  • 1
    @Dave I remember people were complaining about Pi Imager, but I can't find any links on the spot. Care to try Etcher, Win32DiskImager, or dd? Nov 11 '20 at 9:37
  • Thanks for the tip. I tried etcher and dd, no luck. I get same behavior.
    – Dave
    Nov 11 '20 at 17:16
  • @Dave Then I'm out of ideas. Nov 11 '20 at 17:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.