4

I have a strange problem trying to get a Raspberry Pi 400 to display on two older monitors, an HP LP2065 and a Samsung SyncMaster 214t. Both are mid-2000s 1600x1200 monitors with DVI inputs. With both, I have the same issue:

  • When I connect the Raspberry Pi 400 using the right-hand HDMI port (the one next to the power connector), I get a picture that appears to be missing the green component. Sometimes, but not always, there's a red line on the right or the left side of the picture:

Raspberry Pi bootscreen Raspberry Pi desktop Raspberry Pi desktop with resolution / frequency display from the monitor

  • When I connect the Raspberry Pi 400 using the left-hand HDMI port (the one next to the micro SD card), I get no picture at all.

However, and this is where it gets strange:

  • When I connect the Raspberry Pi 400 to a more recent HP Z27n G2 monitor with HDMI input, both HDMI ports work correctly.
  • When I connect a Raspberry Pi 3 or a Raspberry Pi zero to the older monitors, both monitors work correctly.
  • Also, I have used two different cable/adapter combinations. They don't make a difference. Moreover, the HDMI cable that fails on the old monitors works on the new one, and the HDMI to DVI adapter that fails on the Raspberry Pi 400 works with the Raspberry Pi 3.

Setting hdmi_safe=1 or changing the config_hdmi_boost value in config.txt doesn't seem to make a difference, either.

Any ideas?


EDIT: I had the chance to try two more monitors:

  • A Fujitsu-Siemens Scenicview P24-1W -- doesn't work, same issue as the HP and Samsung monitors above.
  • An HP L2445w -- works (through a DVI port, using the same cable / adapter combo that didn't work on the others).

The monitors that fail come from three different brands, but all of them were first sold in 2005 or 2006. The monitors that work were first sold in 2008 or later.

I also learned from here that Raspberry Pis up to the 3+ are using "legacy video drivers", whereas the 4 and the 400 use "new video drivers" as a default.

Was there something in the DVI / HDMI implementation that changed around 2006-2008, where the new video driver no longer supports the old implementation, perhaps unintentionally?

2
  • That looks like a cable fault assuming the monitor works OK with other DVI sources. DVI-D is electrically identical to HDMI without the audio channel. DVI-A won't work. DVI-I may work. – Dougie Nov 11 '20 at 12:00
  • 2
    That was my first thought, too, so I've tried two completely different sets of cables & adapters - both with the same results. And I've tried each part of these sets separately with either the Raspberry Pi or the other monitor, so I'm quite confident to rule that out. – Michael Graf Nov 11 '20 at 12:56
2

My first guess would be incompatible EDID data from older screens, perhaps they are missing some of the colorimetry extensions that the new Pi expects to be there. Consumer displays are moving away from sRGB to newer color standards such as xvYCC and BT.2020, even if the interface stays the same, and perhaps the latest electronics assume different default colorspace if EDID information is not complete.

I would start by checking out the EDID data as seen by the Pi3 and Pi 400 from the same screen:

/opt/vc/bin/tvservice -d edid.dat
/opt/vc/bin/edidparser edid.dat

Perhaps reading out the data on a Pi 3, putting edid.dat to /boot/ on the Pi 400 and setting hdmi_edid_file would do the trick. Or maybe you'll have to modify the EDID file and provide that fake data. Or perhaps you'll be able to select the correct color format with hdmi_pixel_encoding.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.