I plugged a 2,5" USB external 500GB hard drive to a Raspberry Pi 2 (Model B Rev 1.1), but it is not detected:

  • there is no /dev/sda, /dev/sda1

  • lsblk does not display the disk

  • lsusb shows a few things, but I don't know which lines are specific for disks

I added max_usb_current=1 in /boot/config.txt, but it did not change anything.

I can hear the drive working/running.

I suspect the power supply is not powerful enough, so I'll try another one, but is there something else I can try?

Note: the disk is NTFS, but I don't think this is the reason for which /dev/sda, /dev/sda1 is not present. Even if the FS is not readable, I should at least see the disk, and then, be able to reformat it to EXT4, is it right?

  • 2
    You could edit in the output of lsusb. Chances are you are right, it is a power issue.
    – goldilocks
    Commented Nov 11, 2020 at 17:04

2 Answers 2


Plug the disk and run sudo dmesg: There should be lines related to the USB host driver. If there aren't any, either the USB port, or the cable or the disk is broken, to the point there is no reliable electrical connection. If there are messages, they will likely be related to a new USB device not being able to register with the bus. There could be various reasons, ranging from not having enough power to spin up the disk to the disk controller not replying to configuration messages, getting reset, etc.

NTFS will be supported out of the box, although if memory serves you will not have write support until you install ntfs-3g.


I just tried a (n+1)-th USB power supply, and it finally works!

The reason was that the previous power supplies that I tried were too weak (5V, 0.5A).

  • 1
    Added to the Pi's power demand, a 2.5" USB disk drive can take up to 1.2A on spin-up and when seeking, and 0.2 to 0.5A at idle, so it is no surprise that PSU (or charger?) would not supply enough power. Commented Nov 11, 2020 at 18:05
  • Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as an unsolved Post to the community and saves them/us a lot of work.
    – Ingo
    Commented Nov 13, 2020 at 18:35
  • @MichaelHarvey I'm actually surprised the Pi didn't reboot when the drive was plugged in. At least I'd expect it to show the undervoltage icon. Commented Nov 16, 2020 at 7:12
  • @DmitryGrigoryev I was in SSH without any screen, so the undervoltage icon might have been there if I had a display.
    – Basj
    Commented Nov 16, 2020 at 7:41
  • @DmitryGrigoryev - you can have several issues colliding with Pis and power. Most old phone chargers that people have lying around work fine for device battery charging because they can sag to around 4.35 volts on load and still do their job. They don't need to be regulated like a PSU. Many can produce rated volts and max rated current but not both at once. Also a USB HDD is not a consistent DC load. Better to have a power supply that is more than a charger, especially with Pi3 and later and/or when expecting to power a USB HDD. Commented Nov 16, 2020 at 7:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.