On Raspbian, I installed a different desktop environment and selected the wrong one in the terminal and when I rebooted, I went to the MATE desktop environment even though it's not installed.

I tried to right-click for the submenu or reach the terminal, but can't access anything. It's just the background and the movable mouse cursor.

What can I do to fix this?

No icons, text, menus or anything

  • Can you ssh in to the pi from another machine and run sudo raspi-config and select command line to get back to a terminal session? If not enabled - power off, pull the card add a file ssh to the /boot partition and reboot (Pi normally checks every time for this file thank goodness) Does ctl-alt-T work to give you a terminal? Try adding ` init=/bin/sh` to end of cmdline.txt (note leading space) keep on one line - do on another machine. Other machine can be the same Pi with a different SD running and original in an USB SD adapter.
    – user115418
    Commented Nov 13, 2020 at 2:08
  • "What can I do to fix this?" What most of the experienced users would do restore from your BACKUP - indeed I wouldn't dream of performing such a change without a fresh backup. It is not impossible for an expert to rescue a failure but this is usually more effort and risker than a fresh start.
    – Milliways
    Commented Nov 13, 2020 at 5:35

1 Answer 1


I fixed my problem. I pressed [ctrl]+[alt]+[f1] to get to the command line, changed the environment code and rebooted. Solved! :D

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.