4

I followed the steps found here & consulted this site. But I just get complete silence on 100.1 or other frequencies. No sound at all.

Please tell me what it means. I really want to see & use my Pi as an FM transmitter.

  • 2
    Have you solved your problem? If so, please mark the answer that helped you, or if you solved it on your own, create a self-answer and mark it as such. We are trying to get the site Q:A ratio up and marking answers is what does that. If you resolved it and mark then people in the future will be able to profit from what you did and it helps move the site closer to graduation. Thanks! – RPiAwesomeness Mar 23 '14 at 17:06
  • 1
    Using PiFM is illegal in many countries. It produces terrible radio emissions that bleed all over the radio spectrum. The Raspberry Pi Foundation deletes all posts about it on their forum, and those close to the company/foundation warn that “PiFM / PiRate considered harmful. Do not use. – scruss Aug 2 '16 at 22:39
1

I have experienced this problem with my lab Raspberry Pi where a lot of sensors and stuff are connected. Simply install a fresh new raspbian, make updates and upgrades (sudo raspi-config) and try it again. It worked for me.

1

TL;DR: Problem went away after a restart!

I also had this problem. Seems like it won't transmit properly if you have already played audio from a speaker connected to the pi. FM worked again after a restart, but stops working if i play sound from the pi.

1

Problem is pifm uses GPIO 4 This pin is also used by kernel 1 wire devices need to turn these off in /etc/modules and possibly in raspi-config in Advance options Device Tree then run pifm and it should work.

1
  1. Make sure you have correctly identified GPIO pin 4. It's the 4th pin down (4th row) on the inside column.

  2. If you system is heavily loaded, then the frequency can be badly shifted or erratic. Make sure the CPU load is low to nil (verify with "uptime" or "top").

  3. You almost certainly need to be root (sudo or su) to access the GPIO pins (via /dev/mem) [ unless you already addressed this somehow, like via set user ID].

  4. The added wire antenna is strongly recommended. Without it you might fail to pick up the signal.

  5. If you had other processes that used the GPIO since the last reboot, they could be configured wrong. This can happen several ways. See: http://sourceforge.net/p/raspberry-gpio-python/wiki/BasicUsage for a basic outline of the issues.

Hard to know which of these is the issue, but I'll take a wild guess that it's root access or the lack of an antenna. Good luck!

1

For me, the problem was with Raspbian distribution. So , I downloaded latest Raspbian from the site. Then PiFM worked nicely.

Not the answer you're looking for? Browse other questions tagged or ask your own question.