-1

I have been using my Raspberry Pi 3 A+ for a few months now, and recently I ran
sudo apt upgrade && sudo apt update.

After this, the raspberry pi worked fine, but after I rebooted it would show the splash
screen and start booting, but it stops at systemd-hostname.service.

Pressing F4, it shows [ OK ] Started Hostname Service.

The OS is Raspberry Pi Desktop 3.4, with NOOBS installed.

Please help!

3
  • 1
    Grab a new unused SDCard and the RPi Imager tool. Write a fresh copy of plain RaspiOS on your new SDCard and attempt to boot that. – Dougie Nov 17 '20 at 20:21
  • The thing is, I have a bunch of files on my MicroSD Card that I still want. – Tristan Nov 18 '20 at 18:03
  • Restore the files from your backup, or use the fresh flashed SD Card to recover them from the broken installation. – Ingo Nov 19 '20 at 9:00
0

Since you mentioned you want to preserve your current files; first - make a backup of the sd card. I'd highly recommend raspiBackup. Just follow the Quick Start section and you'll have a fully functional backup created right away. You only need a basic flash drive. Second - reformat your current sd card (if no other is present) with a fresh install of your OS of choice and start from there. . . You want to avoid the black hole of attempting to configure issues like this by hand in your current situation. It is far more efficient, and potentially required anyway, to just begin from scratch.

Good luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.