0

I have a problem with my Pi. Every time I turn on the TV it automatically changes the source to my Pi.

I tried following this thread :

stopping RaspPi / raspbmc from auto changing source on tv

Followed the answer solution but I still have the same problem.

these are my /boot/config.txt settings:

# If you get no picture, set the following to "1" to apply most compatible HDMI settings.
#hdmi_safe=1

# Uncomment to adjust the HDMI signal strength if you have interferences, blanking, or no$
# - Values from "0" to "11" are allowed, use values above "7" only if required, e.g. with$
# - Default on first RPi1 is "2" and on RPi2 and above: "5"
#config_hdmi_boost=5

# Uncomment if HDMI display is not detected and composite is being outputted.
hdmi_force_hotplug=1

# Set the following two settings to "1" to disable video output and framebuffer completel$
# NB: This will lead to some error messages on boot, which can be safely ignored.
#hdmi_ignore_hotplug=1

# Uncomment to force a console size. By default it will be display's size minus overscan.
#framebuffer_width=16
#framebuffer_height=16

# SDTV_MODES
#sdtv_mode=0

# Uncomment to force a specific HDMI mode (this will force VGA).
#hdmi_group=1
#hdmi_mode=1

# Uncomment to force an HDMI mode rather than DVI. This can make audio work in DMT (comput$
#hdmi_drive=2

# Set "hdmi_blanking=1" to allow the display going into standby after 10 minutes without i$
# With default value "0", the display shows a blank screen instead, but will not go into s$
# NB: With "1" some applications (e.g. Kodi, OMXPlayer) cannot prevent display standby due$
#hdmi_blanking=1

# Set to "1" if your display has a black border of unused pixels visible.
disable_overscan=1

# Uncomment the following to adjust overscan. Use positive numbers if console goes off scr$
overscan_left=16
overscan_right=16
overscan_top=16
overscan_bottom=16

# Rotation
display_hdmi_rotate=0
lcd_rotate=0

#-------RPi camera module-------
#start_x=1
disable_camera_led=0

#-------GPU memory splits-------
gpu_mem_256=192
gpu_mem_512=320
gpu_mem_1024=320

#-------Max USB current---------
max_usb_current=1

#-------Disable Pi splash screen on boot-----------
disable_splash=1

#-------SoundCard-------
dtparam=audio=on

#-------I²C-------------
dtparam=i2c_arm=off
dtparam=i2c1=off

#-------SPI-------------
dtparam=spi=off

#-------Serial/UART-----
# NB: Enabled for 1st run only, if you want to keep this setting, please set CONFIG_SERIAL$
# NB: "enable_uart=1" will forcefully set "core_freq=250" unless "force_turbo=1" is set as$
enable_uart=0

#-------Overclock-------
temp_limit=75
initial_turbo=20
force_turbo=0

#over_voltage=0
#arm_freq=900
#core_freq=250
#sdram_freq=400

#arm_freq_min=700
#core_freq_min=250
#sdram_freq_min=400

# Note To Self, NEVER enable L2 cache, breaks most X based applications that were not comp$
dtoverlay=disable-bt
dtoverlay=disable-wifi

# This will turn off sending initial active source message to Pi.. So ev ery time you turn$
# go directly to the PI source 

hdmi_ignore_cec_init=1


dtoverlay=vc4-fkms-v3d ```
2
  • Why posting the entire file when it has only about ten lines with actual settings? Nov 18 '20 at 16:04
  • Hi Dmitry, I am not so knowledgeable in Linux. I am just trying to fix an issue I have with my Pi. In my old TV I had to turn it on manually because SSH would not post. I might have changed something back then and it is acting up with this new TV. Do you know the answer ? Or you just like scolding people?
    – snoodler
    Nov 19 '20 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.