I have followed this documentation to set up the wireless access point on my RPi 3B+ successfully by Using this tutorial, but after setting static IP to br0 bridge - Hostname -I says RPI name's as static setup - but to connect to it via bridge

I need to use IP given? by modem stick to even log into ssh... Cant ping static IP being connected to the bridge.

I wish I can just set-up all devices thats connected to that bridge and set up static IP to each of them by my self having RPI thats AP with static IP in this connection as well.

What should I dig into?

2 Answers 2


To easly manage DHCP server on RPI having modem stick DHCP server running with it the easiest way is installing RaspAP. This API provides all the tools thats required for setting up the wireless access point on Raspberry Pi in a standalone network. The Raspberry Pi can be used as a bridged wireless access point like in this case with modem stick connected to eth1 interface.

Static Leasing System provided by RaspAP gives the possibility to mask every MAC address with a static IP like for example TP-LINK ROM's.

Unfortunatly RPI it self cant be managed by static leasing system in RaspAP so it IP is set by the stick it self and luckly stays the same because its the only device connected to it.


You linked to two tutorials and it is difficult to follow what you have done. But there are some general issues that are worth mentioning.

By far the most problems reported here on this site is about static ip addresses and there are tons of answers. The reason is that static ip addresses are a manual intervention into the network configuration and you have to do then all other settings also by yourself. If you do not have enough knowledge about it then let the DHCP server do the work. It knows it better. Or read a general networking tutorial. So I will not invest to another duplicate answer about fixing static ip addresses.

I will give some information about the bridge because it's independent from ip addresses. It does not use ip addresses, only mac addresses. This is also the reason why you cannot connect to the bridge, but only to the RasPi the bridge is working on. You can only connect devices to the access point (or to the ethernet/usb interface). If connected to the AP, its devices seem to be on the same subnet as the ethernet/usb connected internet router: wifi interface and ethernet/usb interface are bridged. You can give the RasPi an ip address but that is not the bridge. It is the RasPi, behaving like any other device on the bridged network. This is mostly important because the bridge itself is completely transparent and cannot be seen by other devices on the network and you may have to manage the bridge on the RasPi. But in general the RasPi do not need an ip address for a working bridge.

So the first step should be to make the bridge working without having focus on static ip addresses. If you can ping the ethernet/usb interface from any device connected to the access point, then this part is done. All ip addresses, in particular the ethernet/usb interface, must be on the same subnet.

If this is working then you can try to set static ip addresses as you would do on an unbridged network. It doesn't hurt the bridge. Just query for static ip address.

With yet another setup that do not need additional helper programs like hostapd and dnsmasq I can help you: Setting up a Raspberry Pi as an access point - the easy way. Just follow section ♦ Setting up an access point with a bridge if you like.

  • You're correct - the number of questions with static IP issues is incredible. What I always wonder is, "Why are so many motivated to use a static IP?"
    – Seamus
    Nov 23, 2020 at 3:16
  • @Seamus Having a static ip address is very easy to understand, in particular for beginners. The device has an address and ready. No need to understand all the confusing stuff about name resolution and DHCP and DNS server and mDNS and default route and gateway and so on. But they don't understand that this is needed and that the DHCP server is made to free them from the burden to understand it.
    – Ingo
    Nov 23, 2020 at 11:04
  • I think that's likely the case... maybe we should start putting it that way? :)
    – Seamus
    Nov 23, 2020 at 20:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.