0

Documenting 2 issues I've faced during installation of Guayadeque on RPi4

  1. wxWidgets not found

-- Could NOT find wxWidgets (missing: wxWidgets_LIBRARIES wxWidgets_INCLUDE_DIRS) CMake Error at CMakeLists.txt:39 (MESSAGE):
wxWidgets not found!

  1. json/json.h not found

h: No such file or directory #include "json/json.h" ^~~~~~~~~~~~~

1 Answer 1

0
  1. Install these dependencies to resolve both the issue

    sudo apt install libindicate-dev libgdk-pixbuf2.0-dev libtag-extras-dev libgstreamer-plugins-base1.0-dev libgstreamer1.0-dev libwxsqlite3-3.0-dev libwxbase3.0-dev build-essential git libcurl4-openssl-dev libdbus-glib-1-dev cmake libwxgtk-media3.0-dev gettext libwxgtk3.0 libjsoncpp-dev

  2. Build. Takes more than 30 mins.

    ./build

  3. Install on Raspbian

    sudo make install

There might be some unused dependencies here, which you can remove with sudo apt autoremove.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.