0

I have a working RS485 shield mounted on my Raspberry Pi device. And I use it successfully for modbus rtu communication. So I am pretty sure that my raspberry device and RS485 interface is ok. I tried to use misty for bacnet mstp communication. But I was not able to start bacnet client. I followed all procedures to set it up. When I try to run code with ini file , I get :

Initialized the socket
mac_address = 25 
max master = 127
baud rate = 76800 
max info frames = 1 
/: Is a directory
RS485: Initializing /

and it stops here. I constantly get the same error "/: Is a directory". I used usb-rs485 converter and also socat virtual serial port. Always gives the same output. it is obvious that /dev/ttySC0 is not directory. My .ini file is :

[BACpypes]
objectName: BACClient
; MSTP Local address
address: 25
; The serial port device
interface: /dev/ttySC0
; other mstp config parameters max_masters, baudrate, maxinfo
max_masters: 127
baudrate: 76800
maxinfo: 1
objectIdentifier: 599
maxApduLengthAccepted: 1024
segmentationSupported: segmentedBoth
vendorIdentifier: 15
foreignPort: 0
foreignBBMD: 128.253.109.254
foreignTTL: 30

So I need a help here.

5
  • / is a directory, and it then does say Initializing /, which is probably not what was intended (/dev/ttySC0 would make more sense), so likely this is a misconfiguration somewhere.
    – goldilocks
    Nov 22 '20 at 18:31
  • When I try “dev/ttySC0” with quotes then it started to say “ is a directory. Nov 22 '20 at 19:58
  • You'll probably be waiting for a long time if you need to wait for another bacnet user, but if you add more information someone else might be able to give you a clue. By this I mean explain briefly what the client is supposed to do (and where it came from), and a verbatim example of you trying to run it -- actual cut n' paste of the command and the response. If you can't cut and paste, copy it by hand exactly as is.
    – goldilocks
    Nov 22 '20 at 20:16
  • No I will not wait of course. I just followed all the steps to use that library with the instructions given by developer. Probably he deliberately did not fix that. I asked aboıt this issue on github page but no answer so far. As you suggest I will dive into source code and find the problem on my own. And if i ll make it i ll post it here. Nov 22 '20 at 22:20
  • That's not what I was suggesting. The issue is you've given a summary of what you did, but you do not know what the problem is. So what details do you decide are relevant for the summary? Or do you instead -- remember, this is important to you more than anyone else -- make as much effort as you can to include all the actual, explicit details? "I just followed all the steps..." What steps? People will not bother and go research this, so it is up to you, again, to provide as much relevant information as you can.
    – goldilocks
    Nov 23 '20 at 15:06
0

The owner of the module misty fixed the problem in the latest version. It lacked the support for python3 and thats what I got such error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.