0

I have a problem with my raspberry pi 4 actually it does boot but only in this conditions:

-if i do a fresh installation of my os on my sd card and I power my raspberry it boots

  • if after that I do a sudo reboot It boots

  • if after that I do a sudo shutdown -h now I Remove power, WITHOUT taking my SD card out, I repower my raspberry boots !

-BUT if after that I do a sudo shutdown -h now I Remove power,take my SD card out, push it back ,repower it won't boot! and if with this same sd card I tried after few hours to boot it boots :(

my problem is that if I remove my sd card for any reason I can't work on my raspberry pi for hours ! how to fix this please because I need to work on to diffrent OS in the same day ! and it is not possible !

10
  • 1
    This is not normal behaviour. I can only assume you have a poor connection between the sd card and its contacts. – joan Nov 26 '20 at 8:54
  • I tried to use another sd card and I got the same behaviour! how can I fix this connection? – mina Nov 26 '20 at 9:08
  • 2
    "sudo shotdown -h now" won't do anything (other than post an error message) – Milliways Nov 26 '20 at 10:52
  • I thought it was safer for my sd card to do a shutdown before removing the power raspi.tv/2012/… – mina Nov 26 '20 at 11:19
  • 1
    It is, but you're running the wrong command. There is a typo. It's sudo shutdown now, not sudo shotdown now. – Unsigned_Arduino Nov 26 '20 at 16:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.